USB Flashing Software - Ventoy or Balena Etcher?

I am trying to reinstall Zorin 16.2 Core on my SSD but I need to first choose either Ventoy or Etcher.

What should I use?

For a one time thing I would use Etcher.

But both work great so you can’t really go wrong.

I tried Etcher last time but I had gotten a brief login error notif everytime I boot up my computer.

Did you make any partitions when installing Zorin via USB Drive?

I only use Zorin so I let it erase the disk and do what it wants with the disks.

But little error messages on bootup are pretty normal. Usually it is nothing to worry about. If you want to snag a picture of it during boot we can let you know for sure

I've already formatted the SSD I had Zorin on.

I will be reinstalling Zorin 16.2 on the now empty SSD I have - the question is though, should I really use Ventoy instead of Etcher as I heard it's really good?

The only real advantage that Ventoy has is you can keep multiple distros on a single flash drive. I use it a lot because I keep Live versions of different distros for testing different things. But if I was just going to install one distro I think etcher flashing it to the drive would be more reliable than how Ventoy works (but that is speculation on my part)

I really do not think you can go wrong with either

Uhhh... I would not agree with this at all... But then, whenever I disagree with you on something, little flames start sparking up around the thread. :stuck_out_tongue:

This is the same for me. And for a user who just wants a one time use and then revert the USB stick to general storage use, an etcher of some kind like Popsicle or MultiBootUSB may be better.
But... I can give a good reason for using Ventoy and keeping the USB with the Live Trial on it: Troubleshooting.

How often is it that we need the user to boot into a LiveUSB of Zorin within a week or two of having installed it?

@Z_123 if @Aravisian recommends Ventoy as more reliable then I would trust him. I would think he has more experience with that than I do.

I have now installed Ventoy into my USB but the login error is still there...

I also tried booting up the Zorin USB Live using modern NVidia option but the same thing still shows up...

What can I do now? I REALLY want to get rid of this "error log" thing.

Can you take a picture of what it is showing with your phone and upload it here?

It's basically a brief notif on the top left of the screen that says "login error" but I know for a fact that is NOT meant to happen so I need to get rid of it.

If you use Linux, then I suggest KDE ISO Image Writer.

Unfortunately, KDE apps only work on Linux.

I've already installed Ventoy onto my USB Drive.

No i'm not going use KDE Again I had issues with it before.

Just the other day, I needed to put Zorin Lite on a USB. In the past, when I was trying multiple distros, I used Ventoy with success. This time as I was only interested in one distro, I tried Etcher. It took a long time, gave some error message during the process (sorry I can't remember it specifically, something like "this ISO contains no bootable partition"), and the resulting USB would not boot.
I used Ventoy with the exact same ISO and everything went smoothly.
Your mileage may vary.

You didn't get any brief login error after installing Zorin OS via USB Drive, did you?

Ventoy is really useful if:

  1. You want to store multiple ISOs, e.g for backup reasons, on one USB
  2. You want to continue using the USB Stick to store your files, but also to restore your installation if something goes wrong

Balena Etcher and other similar programs on the other hand overwrite all data on the USB Stick without a way to store your own data alongside.

So, if you're fine with formatting your USB Drive and loosing the Zorin installer that's on it after you've tried it out or installed it on your PC, you can just use Balena Etcher.

Me? I don't remember any login error when booting from Ventoy drive. But I don't always pay attention to text mode messages if they quickly disappear.

Whenever I boot up my Computer I always see that message, I know that is not meant to happen but I still can't find a way to get rid of it...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.