USB game controller

I have made the change from windoze! Happy with that! Along with making the change to Linux, I thought I'd try minecraft. I have a local server running. I found minecraft bedrock launcher. It works, I want a game controller! What would you suggest? I Borrowed a ps4 wireless, got it connected bluetooth, but does not work with the game. I'd just as well have usb wired. I have been playing with Ipad and steelseries, that will not connect!

Side note: the hold up for making the move to linux was surveillance station. I have security camera's connecting to synology disk station. It run's in WINE! Not as well, but does work.

thanks

1 Like

I recently got one of these for my PopOS gaming machine:
https://www.8bitdo.com/wireless-usb-adapter/
It connects via bluetooth but is seen by the system as a wired xbox controller. I also tried connecting a DS4 to the PC's built-in bluetooth but it had connection issues. With the 8BitDo adapter the DS4 works flawlessly but I also have the option to connect a Switch controller, Xbox One, etc. Should work with the Steelseries one too AFIAK.

1 Like

Weird cause i got the ps4 controller to work perfectly with Cyberpunk 2077. Does minecraft even support a controller ?

1 Like

I'm a gamer on Linux, I use keyboard and mouse, and I use a game controller. I recently went on an adventure to find a controller that will work with Linux games on Steam, and I found one. PowerA wired controllers work. This ones mine bellow.

PowerA Purple Hex variation...
binary-comment
https://forum.zorin.com/t/welcome-to-my-command-center/7740/2?u=startreker

1 Like

Thanks guys, Picked up a logitech F310, can't get it to work either. Don't know much about it. Works in windoze, works on ipad.. maybe does not work linux.

1 Like

Did you try this ?

1 Like

I wanted to let you know a couple of things.

(1) The Logitech F310 is an old model, the technology came out in 2010, and thus might be running an outdated communication standard, much like Xbox360 controllers.

(2) The best website to test gamepads for all operating systems, is. Gamepad-Tester

Make sure to press a button on the controller to wake it up, once you are on the site, and its scanning for it. If no functions are picked up, its possible the system isn't picking it up.

I think you already know about LSUSB

If nothing works, I say return it, and then get yourself a PowerA controller in the variation you prefer.

I tried the gamepadtester show's it's working! Maybe something with the game

1 Like

And a good Starfox will patrol Cornellia and do a barrel role when he discovers baddies, and has to take out the garbage.