USB mouse stops working after 5 to 6 minutes

Totally new user, a first attempt at using Linux!

I have installed Zorin 15.2 64 bit on an old Fujitsu-Siemens Amilo SI 1520.

At start up everything seems to work…but after about 5 to 6 minutes the mouse will stop working properly. The left button stops responding but the right button works. Basically, everything is intermittent. In the end, one is forced to simply turn off, wait a bit and start again.

Grateful for any help…thank you


@lionel1020 Hi and welcome to the Forum.
Is Your Zorin 15.2 Lite or Core?
What type of mouse are you using. Is it USB mouse?
If it is, have you tried another USB port. Even removing and pluggin back in with Zorin running may help.
Does the laptop trackpad and its buttons work properly or is it just the mouse?

Could also have a look at:
Settings>Devices>Mouse & Touchpad
and have a play with different mouse click speeds.


Thankyou for the quick reply.

I am using Zorin 15.2 Core. It is a USB mouse, I have tried all three USB ports with the same result and the mouse works on different PC’s.

At the time the mouse stops working the trackpad also stops working. The problems vary. Sometimes just the left hand button stops, with the right hand button continuing to work…sometimes both…the cursor always works.

The battery on the PC is dead (and will not charge) I was wondering if the power management controls could be cutting the mouse in an effort to save power???

I am going to cut the trackpad today and see if this makes a difference…


I found this on old forum. If you look at bottom post by BrickTop, he suffered similar problem to yours.

I know you say your mouse works on other pc’s, but have you tried another mouse on your Zorin machine to see if any dfferent.

I think I have found the solution!

It would seem there is a tenuous liaison between the touchpad and the USB mouse. I disabled the touchpad which, after a restart, has seemed to correct the mouse.

Today I updated the system, which involved several ‘restarts’ and have noted no erratic behaviour throughout the day.

Thank you for your help.


1 Like

Assume after the updates you should now have latest version i.e. Zorin 15.3 Core?