USB not Booting

I just installed the Zorin 17 core ISO file and flashed it into a USB (using the inbuilt disk image writer and another time popsicle also) and then I restarted, went to the boot menu and selected my USB, but then again, my current Zorin 16 booted up. Same thing happened both the times, using disk image writer and popsicle.

I ultimately want to single-boot zorin 17.
I don't know what the problem is. I downloaded the ISO from the official page, so it must be legit. My secureboot is already disabled.
please help me.

What inbuilt disk image writer? You can't create using Disks on a system that is in use. Is your installed OS Windows? I use Ventoy (for GNU/Linux - this platform only just recently supported, Windows version been out longer). I installed my 17 Beta using Ventoy, no issues. The beauty of Ventoy is that once you have formatted the USB using Ventoy, it installs the program to USB then all you have to do is drop any .iso onto the USB, such as copy to, then on reboot you get a list of all the isos at your disposal, then down arrow to the one you want. If just Zorini present you just select that. It then gives options to boot normally or safe graphics or boot from hard drive.

1 Like


installed os is zorin 16 core

Are you sure you're saving the boot changes in BIOS? Usually F10 to 'save and exit'. Just one thing to check out..

Have you tried another USB port?

Might sound crazy - but you could try using Unetbootin or Rufus to make a Legacy / MBR boot style disk; do you remember if you had to use any Legacy settings to install 16?

1 Like

Rufus is for Windows, he is using Zorin 16. I think Ventoy for Linux is a better option as that is what I used in Antix and added the Zorin 17 Beta .iso to that.

1 Like

Just for keeping it simple - and can absolutely run Rufus through Wine, just fine! :wink:

I would argue that is adding another layer by having to run Windows Application Support. Also, just my personal preference I would prefer not to have any Windows files touching my GNU/Linux and reduce potential attack vectors! :grin:

didnt need to use it.



Awesome, so nothing there should be an issue it seems.

Have you checked the USB after writing it; make sure all info was transferred?

I've been noticing, for a little while, the write caching for USB drives on my end - appears as if it's still writing after 'finishing' the transfer. It may still be writing from cache before being ejected / removed.

Also - have you matched the checksum from your downloaded .ISO with the Zorin site? Might have had some dropped packets from downloading - just another possibility.

And do you have another machine you could test the USB with - to make sure it's bootable?

how to do this?

i didnt remove the usb throughout after writing.

As I would have assumed - just remove and insert after it's finished. Also taking it to another machine to try would be pretty definitive on if it boots or not. If it has an activity light on the USB, you can see if after the dialogue for the image writer is 'finished' or 'done', look at the activity light on the USB drive, that should be solid or off when no activity is being made.

There's the list of the hashes - to check your hash: sha256sum file_name_here in terminal replacing 'file_name_here' with your ISO file name including the '.iso' extension. That'll spit out a string of numbers / letters, then just compare with what's on the site to what you have in terminal. That's just to verify all data has been obtained without error. If it matches, it could be a number of things that could be the cause. Faulty USB be could be one other possibility as well - happened to me a few times.


I had to try twice to get the Zorin 17 Beta to write to USB. Another user reported an issue, then found that just writing it another time worked, as well.

Possible reasons for this may include the phenomenally high traffic of demand for 17 Beta. This may be causing strain on the overly taxed servers.

1 Like

Yay! Zorin 17 Installed. Thanks guys. Not sure particularly which advice helped, I tried all the couple of things suggested here in this try and it worked- checked integrity- Reformated the disk cleanly and then used ventoy, which works amazing- then also waited a long time after it said that it was done-then also safely ejected the usb- and it booted.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.