USB not showing up in Boot Device Menu for Linux Ubuntu

Hi all,

When I powered on my computer, hit Esc, Delete, F12 and it took me to the Boot Device Menu, my USB was not listed as an option.

I have a Linux and my current OS is Ubuntu. Anyone know a simple fix for this?

Flash it again, use a different stick and verify the hash from the iso :grinning:

brand new flash drive, just flashed it through Popsicle, Popsicle verified the Hash, I also verified it through QuickHash. Do you think that's the issue?

Some motherboards have arcane BIOS settings to allow USBs to boot - you may also want to explore your BIOS settings a bit more to make sure you didn't miss anything. I know it happened on one of my desktops (both Asus mobos) but I can't remember which one (or what I did to make the BIOS allow USB booting).

1 Like

Did you have the usb stick plugged in before you started bios? My bios does not give me an option for booting from usb if it doesn't see a bootable usb stick plugged in.


I figured it out. The issue was that I was clicking Esc, and it was taking me to the wrong screen. When I clicked F2, it took me to the correct screen.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.