Usb...port... problem

Hello, recently when I try to insert my usb or my mouse it doesn't work (note that before I post this the usb port was working and suddenly it doesn't work)I tried updating the system put its still doesn't work if there any thing that can solve this problem please tell me and thank you

Welcome! :smile:

I wrote a guide recently on misbehaving USB devices:

Try installing libusb-dev (sudo apt install libusb-dev in terminal), reboot, and then try the mouse again..

That package includes extra drivers and support for a multitude of USB devices that may or may not need the extras. For me, it's a reaction install after the OS install - just to make sure there are reduced mishaps :wink:

What brand / model is the mouse; do you happen to know? Again, in terminal - issue lsusb and post the output with the dongle in the USB port. That'll give a hardware ID; might have a quirk to that device that needs an extra push to get going.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.