USB Ports malfunction and a Microphone-Discord problem


I've finally managed to find something annoying to deal with, two problems i wasn't able to figure out on my own.
USB ports (MPG Z690 EDGE WIFI, all usb versions) are doing whatever they want when i'm turning my PC on. For example:

There are times when mouse isn't working. If that happens i can simply unplug it and plug it back right away which fixes it instantly, but only for one session. Next time it may work or not. It's not switching of during work - only when PC's starting up and not always.
Also, my sound devices are playing around; Microphone takes over external sound cards space. This in particular i can easily fix in settings menu but why it happens?

And finally another annoyance: microphone is working flawlessly. I've tested it many times on many different platforms but for some reason discord is not catching any voice from it, only background noises. Program itself says it does not see any input when tested, which is a blatant lie. Tried everything to no avail, including different discord versions. It worked 2 days ago and now its not. I'm thinking its strictly linux version of discord that's problematic, some small auto-update but need some kind of confirmation on that.

BIG THANKS in advance :slight_smile:

OK, the second part (discord) is no more. My fwends were pranking me big time. It was and is working flawlessly. There is only this USB-related problem which i simply don't know how to tackle. Sorry.

I chuckled when I read this...
Then I read:

It turned out that you were right the first time. :wink:

There are two things I would first check: BIOS / EFI Settings and CMOS Battery.
CMOS Battery may need to be reset and contacts cleaned or - battery replaced.
In BIOS, there may be a path of Settings > System Configuration > USB Configuration where you can enable or disable external USB connections.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.