Usb tethering connection very slow

Hello.. i use ethernet from usb tethering on zorin os but the connection very slow only 10mbps for download and 30mbps for upload... But i use on window 7 with same phone and usb cable the connection get 600mbps to 1gbps.. please help.. i was newbie on this os..

1 Like

Welcome! :smile:

For general USB issues, I would start with installing libusb-dev with sudo apt install libusb-dev in terminal and trying the tether again after a reboot.

What machine are you using; make/model?

Dell optiplex 790.. i3 2100 with 6gb ram

Gotcha - are you dual-booted by chance? I see mention of using Windows for comparison.

1 Like

I use 2 hdd.. 1 hdd i install window 7 and 1 hdd i install zorin os core.. the problem on ethernet connection on usb tethering very slow.. i use only 2.4ghz usb wifi adapter.. i use usb tethering to get 500mbps ethernet connection... I hope u understand because my english not good..

No worries, I've had no issues keeping up so far :wink:

So, having a Windows bootable beside Zorin - what is the status of your Secure Boot setting within BIOS? Windows is completely fine with it enabled.. But, with Linux / Zorin, different story. Secure Boot can mess with hardware, WiFi is one of the biggest ones. Example: I've got Secure Boot disabled on all my dual-boot or full Linux installed machines; just so I don't have any hardware / driver issues.

And - have you tried installing libusb-dev and testing after reboot?

1 Like

Additional questions:
Which Android version are you using?

have you tried modprobing the relevant modules:

sudo modprobe -r usbnet

sudo modprobe usbnet max_usb_current=500

1 Like

I use android 13.. and 5g connection ethernet

1 Like

I also try it.. have a improvement.. but not same on window 7..

U can see the difference

Love CLI speed test - does yield some wonky results sometimes, have to admit. Try using in Firefox - or

Are you certain it's your network speed you're seeing in Windows, and not your link speed? Link speed is different than net speeds, that is just your interface connection - like USB. Or with Ethernet, the speed at which your two Ethernet devices can talk. If you have a Gigabit Ethernet, you'll see your link speed at 1Gbps. With 'Fast Ethernet', you'll see 100Mbps, plus or minus; but not 1Gbps. What you're actually receiving through the USB from tethering your cell network, could be as fast as 1Gbps - but your phone and cell service would have to be pushing that speed to see it. And Windows does show link speed if looking at the connection properties.

Hopefully that makes some sense - from your pics that looks pretty normal for me and what my 5G tethering can handle.

(edit) Here's an article for both if that's too confusing, heh:

After i use this command y speed back to before i (install libusb-dev)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.