Used Grub Customizer - New Theme Works but Fonts Don't - How to Revert?

So I foolishly used Grub Customizer to apply this Grub theme, which looks fantastic. Everything seems to have applied, except for the icons and font, and I'm not sure why. Is there a way I can revert to the original Grub theme that comes with Zorin OS and try to more intelligently customize Grub the next time around?

Running Zorin OS 17 Pro. Thanks for any insight you can provide!

You can try the Boot Repair on the installation .iso file whereby you can tell it to reinstall the grub. I don’t know how well it will work for this case. I used it a few times when I have borked the boot loader having several distributions on an SSD. It worked and I had the Zorin grub back. Your mileage may vary.

1 Like

That's a great idea. I'll try that. Why is theming GRUB so difficult?

I have no idea.

Actually it isn't that much. There are some Stuff to do, yes. But it is doable. First You need Your Grub Theme. Then You must put it in the right Place. On Zorin it is a little bit Easier to do. Why? Zorin already has a Grub Theme. So, You only have to put Your Grub Theme to the same Place.

To explain it with an Example:
Let's say our Grub Theme would call example-grub and the Folder is on the Desktop.

First you open the Terminal and type sudo cp -r /home/[Your-User-Name]/Desktop/example-grub /usr/share/grub/themes/

Then Your Grub Theme is in the right Place. After that you must configure the Grub File. For this You type in the Terminal sudo nano /etc/default/grub

There You scroll to the Line GRUB_THEME=/usr/share/grub/themes/zorin/theme.txt (that is the default Zorin Grub Theme)
At the Beginning of the Line You set a # to comment it out and under the Line You add Your Theme. In my Example it would be:

Then You push ctrl+o for save the Change, Enter to confirm and ctrl+x to close. Then You are back in the normal Terminal Overview. Here You type sudo update-grub
That is important! Without that it won't work. After that all You make a Reboot and You Grub Theme should greet You.

This makes a lot of sense. I was since able to follow Ponce-De-Leon's instructions from here to use the very same theme he uses (as opposed to fully reverting) and, for some reason, while the background works perfectly and the title and footer fonts appear to work beautifully too, the text for the actual entries looks like the default, unicode (?) font. The icons work perfectly fine too, interestingly.

I'm perplexed as I followed his (and your) instructions to the T! That is, I placed the theme folder in both the /usr/share/grub/themes and /boot/grub/themes folders (with the former requiring me to run nautilus using sudo to do so). I tried pointing GRUB_THEME in the grub file to each location and updated grub thereafter in each instance, but the result is the same. A near-perfect grub screen, but with the actual boot entries in that ugly default font. :frowning: Out of curiousity, is there any meaningful difference with the grub theme residing in the themes folder that is nested in /usr/ versus the one in /boot/? Why are there two folders for grub, anyway?

So, You had the Theme in both Folders. But not both active at the same Time in the Grub File I hope. There should only be one active.

Because of the Font: Did You changed the Resolution for the Grub Menu?

That's correct. I tried one location first, and then the other. I didn't change the resolution. I have a 1920x1080 monitor. What resolution are you running? And why would resolution only affect certain text?

1 Like

That is what Your Monitor can handle. But the Question is: Does it is supported in the Grub? You can control it. When you are in the Grub Menu push the c Button. then a Command Line will open. There you type videoinfo or vbeinfo (try what will work) and then You get an Output with the Resolutions. You must not do it. you can try to directly set up the Grub Resolution if You want.

I run it with 1920x1080. You can set it up in the Grub File with sudo nano /etc/default/grub/ in the Terminal. To show You:

It is the first marked Value. If You not changed it before it should be comment out with a # at the beginning of the Line. So, delete the # and then change the Resolution. In my Case You see there stands 1920x1080.

The 2nd marked Value is the Grub Theme Path what I described above. I tought I could show it to You too. So You can see how I made it. Maybe it is a bit clearer to see it.

And when You change the Resolution please don't forget after it the sudo update-grub

I presume it successfully runs at 1920x1080 since everything but the actual boot entries looks beautiful. Sadly, when I try to run videoinfo or vbeinfo I get an error that secure boot forbids launching those. How annoying. I guess I'll just have to deal with the boot entries looking like an old Tandy machine, while the rest looks pretty. :frowning:

I see, thanks for the insight. I'm the only one who uses this computer so, I guess the security issue is moot. But I really remain surprised that something as simple as a boot screen is still so hard to configure. I remember messing around with Ubuntu years and years ago, and ran into issues that eventually got worked out.

One question: is there any value in running sudo update-grub2? In another thread, someone mentioned they had success with fixing something when they ran that command, as simply running sudo update-grub wasn't doing anything. Are there multiple versions of Grub on the machine?

You can turn off Secure Boot in the BIOS. Or - if you want to make an Experiment - You can change the Value without the Check to 1920x1080. Then You look if it looks okay and if not You can change it back.

I've run it at 1920x1080 and can be seen below, everything looks perfect but the boot entries themselves. I don't think this is worth turning off secure boot, especially since Zorin OS otherwise plays nicely with it.

1 Like

Okay, I see. The Entries are looking a little bit small. I understand. Mine is not very big too, but I would say that it is a little bit bigger.

Theoretically You could go in the theme.txt File of the Grub Theme and try to change the Font Size. But I don't know if this would be a good Idea. If this annoys You not too much I would say let it like this. Or You could try another Grub Theme.