Using Bottles

Hello, I just upgraded to OS 17 and eager to try running Windows program using Bottle.

I have downloaded Window's exe file, but when I launched Bottle to try to run the executable, it does not show me any exe file to run. Do I need to do anything else? Thanks again.

The filepicker is funky sometimes, just change it from "Supported Executables" to "All Files" in the bottom right corner.

Just note that appx, msix, appbundle and alike won't run.

1 Like

Not OP, but seeking clarification - is .appinstaller one of the formats that won't run? I have an .appinstaller file that I'd love to get working on Zorin OS but Bottles gives me a "file not found" error when I try. :frowning:

Thanks a lot. Now I got "Please re-run this installer as a normal user instead of "Run as Administrator".

Any idea how do I force bottle to run as normal user?

I've tried to run the exe via wine when I was in OS 16, but I hit error and gave up. Now that we have OS 17, I'm trying out with bottle.

When I ran it via Wine, I get Failed to install .NET framework, try installing the latest version manually. Would you have any idea how do I do it?

I had installed it manually using

sudo apt-get update && \
  sudo apt-get install -y dotnet-sdk-8.0

sudo apt-get install -y dotnet-runtime-8.0

But it still shows me the same error. Am I missing something?

I then, downloaded the .NET Framework 4.8 from microsoft website and it says ".NET Framework 4.8 or a later update is already installed on this computer."

Is Bottle/Wine not supposed to work for certain windows app?

I had the same surprise in crossover, which are strongly linked to the wine project and they told me that unfortunately this is impossible for the moment.

Sorry I can't help.

Have a nice day!

Indeed, that won't run. The underlying compatibility layer - Wine - can run Windows Executables, EXE Files, but it isn't designed to extract or handle things like appinstaller, msix, appx etc.

Technically speaking, they're just special installers that contain dependencies and the EXE File, so we may get a tool in the future to extract and run them BUT most of the EXEs in there still won't run due to new-age windows dependencies that haven't been made to work under Wine yet - and in extension, not under Bottles either.

Wine always runs as administrator, sadly.
(On the Windows end. It doesn't get Administrator/Root access on your actual ZorinOS System)

Wine Mono is included and provides support for .NET
in 99% of cases, you do not need to manually install Microsoft versions of .NET
Additionally, you can head to Bottles > [Your Bottle] > Dependencies and install things like dotnet directly from there.

Installing it onto your system, e.g using sudo apt install won't work as Bottles handles things internally.

Support is indeed not perfect. The Wine Project has had many years to mature, but implementing the APIs of an entire OS that frequently changes is hard and takes time.

1 Like

Thanks so much. I will wait for future update that hopefully can let me run my window app.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.