Using c# in vscode in linux , may make me leave linux

intellisense not working in VSCode when programing with c#, if any one use c# in vscode in linux can help me? I have searched a lot.

image

https://linuxpip.org/vscode-intellisense-not-working/#:~:text=If%20you%20find%20that%20IntelliSense,enough%20to%20solve%20the%20issue.

1 Like

I'm using VS code for Unity. Here is my suggestion
Check these things below

  • installed dotnet
  • installed c# extensions
  • open vscode > View > Output (check any error log showing?)

If you using for Unity 3D?

  • install mono develop
  • open vscode > settings and find this (omnisharp.useGlobalMono) and set (never)
    OR
  • (omniSharp.useModernNet) and set (false)
1 Like

Thank u for all, I have tried all suggested things, but not worked.
I thought the problem may be in c# extension or the sdk .net,
but it seem the problem was related with vscode settings, i solved the problem by setting the vscode settings to default (Press F1 and Type user settings Click the sheet icon to open the settings.json file and delete the file's contents)

1 Like