Using secondary hard drive for storage

I decided to install Zorin OS 16 a couple days ago on one of my PC builds and am having difficulty using a second hard drive as storage for game files. I get an error when trying to point a program such as steam or scummvm to the storage drive saying I dont have permission. I formatted the drive to ext4 when I first installed zorin. The drive does mount when the system boots. When I click properties and view permissions it appears my username is set to be able to read and create files. I have searched online for this but cant find an answer.

Hello dedwards77, welcome to this forum.

I have second partition on the same drive that I use as storage and formatted as ext4.

left it with a size of aprox 725 GB and just like you I use this sometimes to install my games in a separate games folder. Had the same issues about permissions and performed the following procedure to gain access.

sudo chmod 755 -R *

Performed this while the partition was completely empty, so I could easily make directories and copy/paste files. Now I am able to install games and make saves.

dasjdoom I used the chmod on my storage drive but I still get permission denied when I try to open it from a program.

After the commands you should have gained access to the files/folders.
You can see this when using the; ls -l command. The folders and files should be shown as read- and write-able.

Have you tried with restarting your system. As I mentioned I did nothing special just the command and now I have the read and write access to the drive.

Perhaps he needs to change Ownership of the drive ($USER:$USER), as well...

1 Like

I was home on my break when I tried chmod on the drive but I am not sure if I restarted the computer or not. I will have to tinker with it after work this evening. Not sure how to change ownership of the HD.

Identify your drive when the drive is plugged in and mounted:

ls /media

Let's call it "example-drive". Replace $USER with your actual username.

sudo chown $USER:$USER /media/example-drive

Let's say your username on your computer is dedwards:

sudo chown dedwards:dedwards /media/example-drive

I have done that and am still getting the same permission denied error. Is there any way to give an app admin rights in linux kind of like macos promts that an app needs to access drive etc..

ok so I was able to get scummvm access by going to the app settings and turning on removable drive access, now I am trying to get steam to see the drive.

ok so for steam to recognize the storage drive isnt as easy but if I can take ownership of the /media folder I think it will fix the issue. chown is not giving me ownership it stays as root ownership.

1 Like

Opened nautilus as sudo and changed permissions of the media folder which contained my storage drive. Steam still does not see my drive as an option... apparently if I installed steam as a flatpack that could be the problem. I am trying to get to the point of giving up windows but this is the kind of stuff that lets me know linux is not ready to replace windows quite yet (for me at least).

If your using the drive just for games, perhaps another suggestion is to format it to ntfs. I had done that before the ext4. Worked just as well.

Yes, this can cause it. Flatpak and Snap packages are isolated from the system.

I used the Zorin software store, searched for steam, installed the Steam Installer, and then ran the installer. Logged in etc.

I then formatted my 2nd drive using all the standard tools that come with the Zorin OS

system tools > disks > "in left panel select volume to format" > select gear icon below volume > format partition > "name the volume" > select "internal disk for use with Linux systems only" > next

In drive options I set to standby to never > top of title bar > select 3 dot menu > drive settings > toggle on "apply standby time settings" moved slider to never > OK This is optional as I have a 2TB ssd

Went to the Steam app > title bar > selected Steam > Settings > Downloads > Steam Library Folders > selected the plus button > added 2nd drive > selected it > selected 3 button menu at the right of drive info bar > make default

Downloaded a game and worked.

I got it solved with a flatpack override command that lets the app access my other drive. flatpak override --user --filesystem=/path/to/your/Steam/Library com.valvesoftware.Steam

1 Like