Using TP Link WiFi Adapter - Cannot detect any WiFi network

Hello,

I have just installed fresh Zorin OS on my PC computer. I am using the TP-LINK Archer T2U V3 (te7t2uv3) as my default device to connect to the internet. It was working fine on my Windows before on the same machine so it is not connected to the hardware issue.
I have installed the Realtek driver: https://github.com/aircrack-ng/rtl8812au
My PC is recognizing the adapter but the system cannot find any WiFi network, just showing the loading circle with "No networks" text under infinitely.

I have noticed something strange, the netstat -i command gives me:

Kernel Interface table
Iface MTU RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
enp8s0 1500 78155 0 0 0 48443 0 0 0 BMRU
lo 65536 9585 0 0 0 9585 0 0 0 LRU
�7E�-� 2312 0 0 0 0 0 0 0 0 BMRU

The last name is the name of my adapter and it seems to be bugged, i had no idea what does it mean, unless i typed: nmcli device status, which gave me the output:
DEVICE TYPE STATE CONNECTION
enp8s0 ethernet connected Wired connection 1
\3207E\231-\307 wifi unavailable --
lo loopback unmanaged --

And there as you can see is the full interface name of the adapter (\3207E\231-\307). I don't even know if naming causes the problem or something else.
I spent many hours on this problem, did some research and tried to fix this but I am now faithless and tired. Anyone has a similar problem or maybe know what causes the issue?

Thank you so much in advance.

Hopefully this Linux Mint forum solution should help you out:

https://forums.linuxmint.com/viewtopic.php?t=311501

I have found this and tested already, does not helping. Btw there is no dkms-install.sh file in this repo anymore. I have copied it from another but also didnt worked for me. But thank you anyway :slight_smile:

A different adapter but might work?

Still not resolved :confused:

I'll leave another video on the matter... no guarantees though, these type of issues are a pain:

Try this then

When searching for a solution you can use a search for Ubuntu 20.04 as well as Linux Mint. 99% of the fixes should work on Zorin as well.

Back to square one. Please open a terminal and enter:

lsusb

and post back the results.

lsusb

Bus 002 Device 008: ID 2ea8:2122
Bus 002 Device 010: ID 04e8:6864 Samsung Electronics Co., Ltd GT-I9070 (network tethering, USB debugging enabled)
Bus 002 Device 003: ID 2357:011f TP-Link
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 09da:7f72 A4Tech Co., Ltd.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

iwconfig

lo no wireless extensions.

enp8s0 no wireless extensions.

usb0 no wireless extensions.

�7E�-� unassociated ESSID:"" Nickname:"WIFI@REALTEK"
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

OK thanks for the info. Your device is not supported even with latest kernel of 5.18:

I suggest you look for dedicated hardware here:

https://www.thinkpenguin.com/catalog/networking-gear-gnu-linux

1 Like

Thank you very much :slight_smile:

A post was merged into an existing topic: Is Zorin 16.1 compatible with Wifi 6 routers?