V16.3 works fine, install v17 and "OS not found" is all I get

I'm on an HP Zbook17 G2, 24gb RAM, 1tb hdd. Solid PC that I know well.

I've installed v16.3 numerous times. Each time I let the installer delete all partitions and install clean. All options are left as default. Never a problem.

I was wanting to look at v17, so I followed the same procedure. The install appears to proceed normally, no errors or warnings. BUT- after rebooting the screen displays "Boot Device not found. Please install an operating system on your hard disk"

I immediately reran the v16.3 install, and the machine booted up after install with no issues.

I've reset the BIOS setting to factory (run install. fail), changed to LEGACY boot (run install. fail), changed to UEFI with CSM (run install. fail), UEFI without CSM (run install. fail), sacrificed livestock, bayed at the moon naked, offered a controlling interest in what remains of my soul to powers profane (the devil and Elon Musk, in that order. No takers).

I'm running out of ideas and hair to pull out. Any thoughts would be oh so gratefully accepted.

Thanks for any assistance.

1 Like

This had me rolling.

This appears on HP notebook computers - I am not entirely sure why.
Things that you can try:
Hard Reset the notebook. Remove any docks or USB Hubs and disconnect any usb devices or external monitors. Unplug the A/C adapter and shut down the computer. Hold down the power button for 20 seconds or more to bleed the capacitors.

Then try booting without plugging anything else in.

If no good:

  • Test your RAM
  • Check boot order
  • Restore all EFI Settings to default - I think it is F9 - then set all BIOS configurations to default.

I didn't mention the scars (literal and carved upon my psyche) from 20 years in IT. With special credentials in cursing HP in otherwise forgotten dialects (ancient Sumerian is good, but pales in efficacy beside the original Klingon).

Something obviously changed between v16.3 and v17, as at this point I've probably done more than a dozen installs (might be close to 20 actually) of 16 with ne'er a problem. V17 gives me no errors during installation, but always the same outcome. I've used an external program to scrub the disk first, then run the installer with no change.

Boot order has been checked/changed multiple times. ALL settings defaulted and changed likewise. RAM and HDD both tested and passed several times. I'm still a Linux noob, but I rock hardware.

Thanks for all the suggestions.


Are you installing Zorin OS 17 on an internal drive?

The machine is configured with one internal 1tb hdd, in the default bay. There is the option for a second M.2 SSD, but that is not installed at present and does not appear on the device list in the BIOS boot order at present.

This does seem particular to 17, since 16 is installing fine. The usual culprits like RAID vs AHCI can be excluded.

Can you try booting into LiveUSB, then run the Grub Repair:

If it successfully completes, test booting into Zorin OS 17.
If it fails, please send a link for the logfile.

1 Like

I know, it is soul destroying having to keep repeating "Have you tried turning it off and on again?" every 2 mins :slight_smile:

In your HP's BIOS, are there any extra security setting over and above Secure Boot that may be interfering?

I assume you did check the validity of your Z17 download .iso SHA256 against published value before use?

Can you run Z17 OK in "Try ZorinOS" mode from USB?

I don't see from your posts that you intend to dual-boot Z17 with another OS, but please confirm.

1 Like

OK. Problem solved- sorta... I have my Zbook booting Zorin OS 17.

I only got here because when it comes down to it, you NEVER want to tell me not to do something. (Childhood trauma, or am I just an a-hole?) This was the mistake HP made when the put that warning right next to the big shiny button labelled "Factory reset BIOS?" Up until now, I've repeatedly used the "reset all settings to Default?" option. This time I was sleep and sugar deprived, and absurdly ready to burn it all to the ground.

After completing the reset, I get a half dozen error lines on boot complaining of "communication error with TPM chip", but that is not critical at this time. What IS important is that after this reset, I once again ran through the v17 install, performed identically with the last dozen attempts, only THIS TIME IT WORKED!!

I don't know what triggered this issue with v17 specifically, when 16.3 never had any issue. Hopefully the developers can take a look in their copious free time (snort!).

FWIW: prior to this, I did run the Boot Repair utility on the last (non-functional) installation. The log file is available at http://sprunge.us/z74yXJ.

I've requested that Buttercup the Emotional Support unicorn attend the Easter Bunny during his convalescence. It is up to 337harvey to deal with his hundreds of incensed offspring.


I know it may have been down to magic with a sprinkling of science, but do you think your last post #9 can be marked as :ballot_box_with_check: Solution ?

Done. And thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.