Various Issues After AmdGpu Driver Install Attempt

Hi. I tried these instructions for installing amd drivers:

Someone told me my pc's OpenGL is only version 3.3. But my gpu is capable of OpenGL 4.4 afaik (Radeon HD 5770)

Step 1 - "Official Radeon Open Source drivers (recommended)"
My gpu was produced before 2012. So I have to try step 2

Step 2 - "Proprietary AMDGPU-PRO drivers"
After doing this part:

  • my screen's resolution is messed up (Zorin's Display settings say: 1024x768, 76Hz) I can't change these
  • but my monitor's settings says the proper 1080p 60Hz
  • Blender 3d software won't open anymore
  • my gpu's fan is full blast non-stop
  • the terminal command, radeontop, no longer works. It asks if I'm root. So I can't check if my gpu's under lots of load.
  • before pc finishes booting, it says:
    [ 4.479646] hdaudio hdaudioC0D3: Unable to configure, disabling
    (I dunno if this is irrelevant)

Step 3 - " If the AMDGPU-PRO graphics drivers are still not activated"
I tried this, I but noticed "Secure Boot" was already off.
I clicked "off" again, anyways,
but then my desktop wouldn't start up at all.
It just said: "Reboot and Select proper Boot Device or insert"..."
Turning Secure Boot on brought me back to Step 2.

How can I fix this?
Also, any ideas how I can get my gpu's latest OpenGL version on my pc?

Amd-pro drivers are geared towards FireGl and Pro-wx cards.

But usually if the drivers don't work with a supported - its SecureBoot is enabled, or conflicting drivers, ie you might have a an apu + gpu

Also what errors/issues were you getting with OpenGL on the standard drivers?

1 Like

hdaudio hdaudioC0D2: Unable to bind the codec - is most likely due to the amd-pro hdmi audio drivers not working with your card,



when booting and see if that works

Thanks for the reply.
I have an i7-3770 cpu, which has an iGpu.
I decided to use the Hd 5770 dedicated gpu tho since it's a bit faster afaik.

I couldn't open Blender 4 alpha (it's a 3d app).
I was told my gpu has been deprecated for Blender for a while, but that updating drivers might help.
Also, sometimes when I try someone else's 3d shaders, it doesn't look the same as their screenshots/tutorials.

They read this:
System Information
Operating system: Linux-5.15.0-79-generic-x86_64-with-glibc2.31 64 Bits, X11 UI
Graphics card: AMD JUNIPER (DRM 2.50.0 / 5.15.0-79-generic, LLVM 12.0.0) X.Org 3.3 (Core Profile) Mesa 21.2.6

And they said I only have OpenGL 3.3

Ok, so I found drivers specific to my gpu from amd.
Should I download and install one of those?
Or do I have to do something else before proceeding?

Since the gpu is depreciated for blender it may not work as it is unsupported by the app itself. I have a rx580x and its still supported, so blender worked before and after upgrading mesa/ogl

However use this guide to upgrade to the latest mesa/open gl drivers, I tested it and didn't seem to break anything on my system

I tried a bunch of stuff. But my pc can't confirm the Mesa version, can't install an amd driver,
and I still have all the issues (Blender stopped working, etc).
If possible, I'd like to avoid reinstalling Zorin OS.

What I tried:
(If u need more details, let me know. I took screenshots)

Unable to install fglrx: The following packages have unmet dependencies:

^But this error message just ends here without actually listing anything.
^Edit: it says "Download size: 0 bytes". I made sure I downloaded this installer successfully. "Installed size" is 58.1MB

  • I tried some of amd's instructions for unmet dependencies, but it just says:
Picking 'gcc-10' as source package instead of 'lib32gcc1'
E: Can not find version '10.5.0-1ubuntu1~20.04' of package 'lib32gcc1'
E: Unable to find a source package for lib32gcc1

It still says this after these next steps I did:

  • I tried the Mesa link you sent.
  • at first, it didn't work
  • so I tried the purge-and-reinstall part. I think it worked???
  • but my pc can't confirm my Mesa version, even after I restarted my pc, and checked for updates with both "Software Updater" and the "Software" store-like app.
  • And I still have all the pc issues as before

But after all this, I did notice an amd64 flakpak upgradable (see pic plz).
How do I upgrade it?
P.s. i don't have an amd cpu.

Edit: I uninstalled the bad amd driver that messed up my pc. No change tho, even after restarting pc and checking for updates.

edit: I came across this link:

But I'm afraid that I might make things worse with this.

Thanks for your help.

As AMD Radeon graphics drivers are included in the kernel and your card dates from 2012, I wonder if installing and using the 5.8 kernel may be the way to go:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

You will need to use the Grub Menu > Advanced Options for Zorin and select Zorin on 5.8.0-63 to boot up.
Check once logged into the desktop with

uname -r

Test graphics...

1 Like

Still not working.

So I did what you said, did "uname -r" and it says:

But the issues still remain.
Blender won't open like it used to,
I still can't use that amd driver,
and I still can't find which version of mesa i installed.
I restarted (with 5.8.0-63), and ran software updater. Still doesn't work.

Any other ideas?
If not, I might just back up my data and reinstall my Os... I'll have to set up all my shortcuts and other stuff again... :confused:

I'm all out. Aside from digging deep into Mesa which at that point, you really are better off doing a fresh install anyway due to how mesa works.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.