Veracrypt 1.26.7 (latest) : unable to install on zorin core 17.1

Hi,

I need to install veracrypt for work purpose, but i'm unable to install it on Zorin core 17.1. No issue with previous Zorin versions.

When trying to install the deb package : veracrypt-1.26.7-Ubuntu-24.04-amd64.deb

Error => installation failed
Dependency: libgtk-3-0t64 but it is not installable
Dependency: libfuse2t64 but it is not installable

I cannot find these packages with apt...

Any tips ? Or is there any softwares available to open/mount veracrypt files in Zorin 17.1 ?

unit193 is not the maintainer of veracrypt, but he is a well-known developer. You can see the updates here: Encryption software : Unit 193

sudo add-apt-repository ppa:unit193/encryption
sudo apt update
sudo apt install veracrypt

2 Likes

I use cat /proc/version to see the ubuntu version that zorin version is based on.

In Zorin 17.1 its show:

Linux version 6.5.0-35-generic (buildd@lcy02-amd64-079) (x86_64-linux-gnu-gcc-12 (Ubuntu 12.3.0-1ubuntu1~22.04) 12.3.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #35~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Tue May 7 09:00:52 UTC 2

Ubuntu 22.04

1 Like

Interesting, mine is...
Linux version 6.5.0-41-generic (buildd@lcy02-amd64-120) (x86_64-linux-gnu-gcc-12 (Ubuntu 12.3.0-1ubuntu1~22.04) 12.3.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #41~22.04.2-Ubuntu SMP PREEMPT_DYNAMIC Mon Jun 3 11:32:55 UTC 2

Updated recently? I updated last week and now I see that there are new updates, including for Zorin Base.

Yeah, that was probably it, did one just the other day. Forgot about it as it came through late.

The build for ubuntu 22.04 was the good one, my bad. So this is the deb package to install : https://launchpad.net/veracrypt/trunk/1.26.7/+download/veracrypt-1.26.7-Ubuntu-22.04-amd64.deb

I think veracrypt is only software (between 100+) i need on the fresh install that i can't find in the software center.