Veracrypt Issue

Hi all, I have recently installed Veracrypt on Zorin but it doesn't want to start when you try and run it. No error messages, just nothing happens when you double click the icon.

Anyone encountered this before and have any ideas?

Try start it via terminal, and see what it says.

This is a very stupid question on my part, but how do you do that? aha :slight_smile:

You can open terminal with the keyboard shortcut ctrl+alt+t
Or from the App Menu.
Then type into it the name of the application you want to launch.

veracrypt

Ah, I didn't know it was THAT simple :slight_smile:

Here is the output from the command:

1 Like

Can you run in terminal:

sudo apt update && sudo apt upgrade

Test Veracrypt. If still no good:
Then

sudo apt install libstdc++6 libgcc

If that installs, try Veracrypt again. If it says it is already installed, then that means Veracrypt has an error in its configuration files (Bug report to Veracrypt developer) and you must direct it where to look.

1 Like

Hmm, I tried the above and didn't make a difference. When I got to the install libgcc command, it bounced back and said "Unable to locate package libgcc"

1 Like

Try just

sudo apt install libstdc++6

1 Like

I tried that, and it bounces back with the following:
Screenshot from 2022-03-21 09-53-42

Do you have a veracrypt directory within your home directory?

I don't appear to have one no.

Perhaps u tried to install it before and it has some leftovers/in-dependencies. If so try removing them and proceed again with a clean install, like Aravisian suggests.

Yeah, I have removed it and tried to reinstall it and just run into the same problem. To be honest, I'm almost on the verge of giving up and maybe trying something else. Veracrypt would be nice to use, but that's 3 days now I have been battling to try and get it working. There's little to no documentation support on their website, you're pretty much left to swing in the wind and figure it out yourself. I found myself muttering "If this was Mac or Windows it would have worked from the beginning......" Which isn't what I want to be saying :rofl:

1 Like

And just as I typed this, I got it working. I went onto their website and checked their downloads. I noticed I had downloaded the latest Ubuntu version - figured I would instead download the latest Debian 11 version, worst thing that can happen is it doesn't work.
Installed it and boom, it ran first time flawlessly.
Now I'm man enough to accept this was possibly down to user error on my part. I admit I still don't know if an Ubuntu or Debian package is the preferred modus operandi for Zorin so I figure I'll try everything and see what works :smiley:

2 Likes

I don't know what veracrypt is, have never used it. But just visited the site and found the .deb file with GUI. This one is for the Ubuntu 20.04 version.

GUI: veracrypt-1.25.9-Ubuntu-20.04-amd64.deb (PGP Signature)

Perhaps you can try to install that, they often get installed with the common dependencies.

Edit:
Saw your message right I posted it this. Good job, you got it working.