Very slow wifi speed in Zorin OS 16.3

output of lshw -c network

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 15
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.15.0-78-generic firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:44 ioport:2000(size=256) memory:d1604000-d1604fff memory:d1600000-d1603fff
       description: Wireless interface
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 1a
       width: 64 bits
       clock: 33MHz

Are you dual booting with Windows?

no i had completely shifted to zorin 16.3

Ok, just checking since Windows being in hibernate instead of fully shut down can retain control over the wifi hardware.

Let's start here:

Add repo:

sudo add-apt-repository ppa:canonical-hwe-team/backport-iwlwifi

Update sources and install backport driver

sudo apt update && sudo apt install backport-iwlwifi-dkms

Reboot and test wifi speeds and performance. Please relay if no improvement.

no improvement speed is same.

Can you run:

sudo nano /etc/gai.conf

key down to around line number 54.
You should see:

#    For sites which prefer IPv4 connections change the last line to
#precedence ::ffff:0:0/96  100

Remove the hashtag in front of #precedence ::ffff:0:0/96 100
It will look exactly like:

#    For sites which prefer IPv4 connections change the last line to
precedence ::ffff:0:0/96  100

Tap ctrl+o to overwrite. Then enter key to save as current config. Tap ctrl+x to exit the editor.

Reboot and test speeds...

no improvement.In windows it was giving 110-120Mbps.Now in zorin it is dropeed to 3-5Mbps.

So far, the changes we have tried above are safe and you do not need to undo them if you do not want to.
Is this a notebook computer, not a desktop?
If it is a notebook computer, try:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

You should see wifi.powersave = 3.
Change the value to 2.
wifi.powersave = 2
Tap ctrl+o to overwrite, then enter key to save current configuration. Tap ctrl+x to exit the editor.

this one i had already tried.

1 Like

I have been searching the web for answers on this. I have found users on Ubuntu, POP_OS, Mint and other Ubuntu based distros all voicing this. So this is possibly an Ubuntu thing.
I have seen what we tried here in this thread across a variety of other forums and reddit and elsewhere.
I have seen some we have not tried - but I doubt they will help (and in fact in most, the other suggestions did not help that user, either...)

I have seen quite a few say that changing their kernel fixed it. Most of those said that they changed to the 5.8 kernel to fix it. At that time, 5.8 was a new kernel version.
You are on the 5.15.0-76 or 5.15.0-78...Unless there is a regression on later kernels...
You could try it, too. The kernel contains the Intel wifi6 ax200 drivers.
It just would seem odd to me that the 5.15 would regress that badly.

You can try the 6.2 kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.02

Reboot into the 6.2 and test...
If that fails, we can try rolling back to an earlier kernel.

What a frustrating thing.

changed the kernel version but the speed is not stable sometimes it touches 70-80Mbps and now the speed again became 3-5Mbps

Here's a guide that you may want to read :point_down:.

Gday @gaurav ,

!st run the "Software & Updates", there has been many alternative drivers for your system.
Hopefully this will help.

If no luck
If possible change the wifi around (Ethernet to laptop,Then hot spot to another device & checks speeds)
i assume your running 5Gh, try 2.5Gh.
You may also look at BIOS power setting, (performance, Normal, economy, etc)
You could also check if your BIOS firmware/drivers are up to date.
Hope this helps.

Could we ask you to update your Profile to show the Zorin OS Edition your using.
How to here

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.