Video failure after update - static horizontal bars on screen

@Aravisian @PlumpKibbles
Apparently my grub is not strong.

grub>sudo nano /etc/default/grub
error: can't find command 'sudo'
grub>nano /etc/default/grub
error: can't find command 'nano'
grub>cd /etc/default/grub
error: can't find command 'cd'

So far the only command it found was 'cat' :smiling_face_with_tear:

No worries, for that, I would suggest using the Advanced boot option to drop to a root shell (recovery), re-run the commands, then reboot. Or, how @seanhinkley posted with Ctrl+Alt+F3 after logging in with your user.

I think this - since the O.P. would need to be able to access the Grub Menu in order to use the Recovery Menu.

Followed by my post that Ctrl+Alt+F3 didn't work. Plus, how does one log in without getting as far as a login prompt?

using the Advanced boot option

How does one access the "Advanced boot option"? We've already established that the only thing I can raise is this grub> prompt.
Again, I apologize for the inability to interpret your suggestions, but it seems like we're going in a paradoxical circle here.

  • I see a big white Z during the boot.
  • I can press Esc and get a grub> prompt that runs cat and little else.
  • I can wait until the screen tries to load the login, at which point the display fails.

Suggestions that I "log in" - or do something more than type something that works with this prompt - will need to contain a lot more context for me to get it. More apologies for my obvious ignorance here.

1 Like

The default timeout on Zorin OS is 10 seconds.
I do not know what changed your default... It could not have been a theme or anything like that. Certain Applications like Grub Customizer could do it.

This post clearly demonstrates that you are not as ignorant as you claim. :wink:

I agree with you - we seem to be stuck in a circle.
You need access to Grub Menu or to Login in order to proceed. You cannot because the grub menu timeout is set to 0 seconds and also to Hidden.

My suggestion at this point is to create a LiveUSB of Zorin OS - just as you had made when you installed Zorin OS.
Boot into the LiveUSB.
Then we can Mount your installed partition and see if we can access grub file from the LiveUSB. We can go step by step at that point.

From your first post:

Screenshot from 2023-10-11 23-40-34

And at that point like @seanhinkley states, after logging in to get a terminal, using the keys Ctrl+Alt+F3:

Am I missing something? :thinking:

hit ctrl+alt+f3

It does not do anything.

Which screen are you issuing the keys, at the grub> screen? I just had to reboot, tried it, does work lol but not in grub.

Off Topic

I am unable to test this... but if you are in a testing Mood... would you be willing to test if holding the esc key instead of tapping it brings the Grub Menu?

Yep, gimme a sec..

1 Like

Got kind of a weird response: Guess it's just an Asus thing - got a boot device selection, selected Ubuntu - still holding Esc, and got to the grub> prompt. Spazzed out on me but did get to that point. I didn't get to a grub menu though. I'm going to try something else real quick..

So, I tried holding shift and some other F buttons and nothing worked for me. Likely due to my F-toggle buttons for sound and others - I have kind of a sticky-keys for that so I don't have to use the Fn button with the FX buttons. Just something to note..

1 Like

Nope, sorry. It just generates a series of repeating grub> prompts down the left side of the display.

I'm gonna turn it off and let it cool for the night. The screen shot in my OP is only flashing for a few seconds now before it all goes dark. That's when I'm trying the ctrl+alt+f3 combo.

My suggestion at this point is to create a LiveUSB of Zorin OS

Makes sense I think. :slightly_smiling_face:

This post clearly demonstrates that you are not as ignorant as you claim.

But I'm not Dunning–Kruger smart either. :wink:

1 Like

Well, if you get to that point, you could run for President...

I think it is our best chance - the next stage will be backing up your files and reinstalling Zorin OS. This time, learning our lessons and ensuring Grub is accessible and that you do not exceed your kernel.

I have heard a few people say holding esc works. However... I understand that it must be tapped, not held. If held, it counts as only one key press event, whereas tapping can line the timing up of the keypress inside the grub timeout window (repeated tapping means more chances of hitting your target).
I figured it was worth checking, real quick.

2 Likes

In regards to the above:

First, ensure you have your Root Ext4 partition:

sudo blkid -o list

Note the device I.D. for the one with FS-type ext4 and mount point is /
It may look like /dev/sda3 or /dev/nvme0p1...
It depends on what your drive is. If in doubt, snap a picture and share it here.

Next, mount it. This command will look like this if we use my example of /dev/sda3 from above (remember to replace this example with your actual device I.D.):

sudo mount /dev/sda3 /mnt

Necessary directories dev, sys and proc must also get mounted:

sudo mount --bind /dev /mnt/dev

sudo mount --bind /sys /mnt/sys

sudo mount --bind /proc /mnt/proc

Check cat /etc/fstab and ensure that the entry for /boot points toward your mounted partition. If It Does Not - then note that device I.D. and mount it as well, same as you mounted your partition above (I do not see it likely your boot is pointing elsewhere... But better sure than not).
Run

sudo chroot /mnt

Now:

sudo nano /etc/default/grub

Use your arrow keys to navigate. Move the cursor to the Grub-timeout and add one character: 1 in front of the zero to make it ten seconds.
Once you have done that and it looks like
GRUB_TIMEOUT=10
tap ctrl+o to overwrite the file. Tap the enter key to save current configuration. Tap ctrl+x to exit the editor.

Run

sudo update-grub

which will work since you are on your Mounted partition.

While we are at it... We may as well remove the troublesome kernel, too:
If it was the 5.15.0-86 then this command will suffice. If it was a different one, replace this with the version you need to remove. (If uncertain, you can use
dpkg --list | grep linux-image
to see the installed kernels):

sudo apt remove linux-headers-5.15.0-86-generic linux-image-5.15.0-86-generic linux-modules-5.15.0-86-generic linux-modules-extra-5.15.0-86-generic

This way, that issue will also be hopefully solved so you can just boot up and log in.
Once all of the above is done, unmount everything (the actual command is umount):

sudo umount /mnt/dev

sudo umount /mnt/sys

sudo umount /mnt/proc

If you needed to also mount boot earlier, do not forget this one... Otherwise skip this line:

sudo umount /mnt/boot

Continue with this line:

sudo umount /mnt/

At this point you can reboot, remove the LiveUSB and test...

Try this guide:

Has been pointed out to me that gksu command is now deprecated. Apologies:

https://super-unix.com/ubuntu/ubuntu-how-to-create-new-gksu-command-based-on-pkexec/

@Aravisian The only change mentioned in these/your instructions is to modify GRUB_TIMEOUT to 10

because the grub menu timeout is set to 0 seconds and also to Hidden.

That seems to imply that I should also be setting GRUB_TIMEOUT_STYLE to something else besides "hidden"
Can you provide any insight or suggestion there? Thanks.

1 Like

Yes, you can set that to
GRUB_TIMEOUT_STYLE=menu which will make the Grub Menu always appear.

With it set to hidden, it is hidden unless made to appear either by a lengthy timeout or a user key press event. So it is not necessary to set the value to menu to make grub appear. It is just two different settings, both of which can cause a hidden menu and offer different ways of handling it: Always appears or appears only on call.

You can also revert these and tweak them a bit once your system is restored and up and running to match your comfort levels.
Such as changing it to be Always Present - but only for five seconds for example.

2 Likes

So the PC was cold when I booted for the first time this morning. In a riff on something @MCHenry22 mentioned, I restrained myself and just tapped the Esc key one time the moment there was any sign of life, then sat on my hands.
Maybe this placed the keystroke into the buffer before any Grub TIMEOUT was even started (I dunno, totally a guess), because the elusive and revered Boot Options Menu finally appeared after a second or two. As the inability to get this was behind most of your help here, a choir sang and trumpets sounded. :postal_horn: :notes: :trumpet: :zorin:
I was able to select kernel 5.15.0.84 (instead of 5.15.0.86) and the login & desktop loaded just fine. No more broke video.

I wept, then I opened the terminal and followed @Aravisian's tips:

sudo nano /etc/default/grub

Changed
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu
(that last entry because I'm more than happy to hit Enter one extra time during bootup, as a memorial to this experience. Never forget. :wink:)
Save (ctrl-o) & exit (ctrl-x) nano, then run

sudo update-grub

Finally I removed the errant kernel with

sudo apt remove linux-headers-5.15.0-86-generic linux-image-5.15.0-86-generic linux-modules-5.15.0-86-generic linux-modules-extra-5.15.0-86-generic

A final reboot and I am now strong. "Darmok and Jalad at Tanagra", and any other TNG references which apply.

Here's the output from the kernel removal, the conspiracy theorist in me wants to blame that nvidia stuff for my desktop display going south:
Removing linux-generic-hwe-20.04 (5.15.0.86.96~20.04.44) ...
Removing linux-headers-generic-hwe-20.04 (5.15.0.86.96~20.04.44) ...
Removing linux-headers-5.15.0-86-generic (5.15.0-86.96~20.04.1) ...
Removing linux-image-generic-hwe-20.04 (5.15.0.86.96~20.04.44) ...
Removing linux-modules-nvidia-525-generic-hwe-20.04 (5.15.0-86.96~20.04.1+1) ...
Removing linux-modules-nvidia-525-5.15.0-86-generic (5.15.0-86.96~20.04.1+1) ...
linux-image-nvidia-5.15.0-86-generic: removing .ko files
Removing linux-signatures-nvidia-5.15.0-86-generic (5.15.0-86.96~20.04.1+1) ...
Removing linux-modules-extra-5.15.0-86-generic (5.15.0-86.96~20.04.1) ...
Removing linux-modules-5.15.0-86-generic (5.15.0-86.96~20.04.1) ...
Removing linux-image-5.15.0-86-generic (5.15.0-86.96~20.04.1) ...
/etc/kernel/prerm.d/dkms:
dkms: removing: nvidia 525.125.06 (5.15.0-86-generic) (x86_64)

Thanks to everyone for sticking with this.

3 Likes

I do not think that would be a Conspiracy claim, given that there is verifiable evidence in its favor.:wink:

2 Likes

You won't have to hit enter, after 10 seconds you will automatically boot to the default or last booted OS.

I have Zorin set as the first entry, so is the default.

All of the nvidia drivers you tried will be installed on the system. While recommendations are made to you to update, you can always place any apt software on hold (even the kernel) so that it requires you to manually install newer versions (apt will ignore it for an update & upgrade). sudo apt mark [package name].