Video plays without audio

I did this now, didn't change it, unfortunately. When I'm playing media (Video/audio) on certain apps just nothing happens. The media won't play at all or it will play, but without audio :confused:

Both of these worked now. Not sure how a font package would help me with my problems though :sweat:

Any other ideas? Is it maybe in the Nvidia X Server Settings? I have no idea what to look out for :confused: Not being able to play most of the media is a little bummer though :sweat:

For clarity... the commands worked and you can now play videos with audio?
Or the commands worked but you still cannot play video with audio?

Haha sorry for not being precise. I still cannot play video with audio, it depends on the app I'm using for playback though. VLC working fine, Messenger apps like Telegram and Whatsapp are not working and the only music player I use isn't working either

How did you install telegram and whatsapp? Are they installed through apt or .deb package?
Or through flatpak or snap? If you used the Software Store, Zorin OS includes a Button on the titlebar that displays the Source.
Which Music player are you using and how was it installed?

1 Like

As for Telegram I tried both methods, via their website (which is a method I'm not sure of. You download a .tar.gz file, open it and then click on "Telegram" and it's installed :thinking: ) and via the Zorin Software store, both have the same problem on my machine. Didn't try with snap yet, but will do so now :+1:

Whatsapp was installed through the Zorin Store as well, as a Snap I believe.

The music player I'm using is probably not so common here, but as I'm hosting a Plex Server on my Zorin machine, I'm using Plexamp to playback my music collection and I have genuinely no idea which method this used to be installed. You download an AppImage, click on it and then it's there, so not sure :see_no_evil:

And thank you for chiming in for the 300th time or so @Aravisian

Is audio even set to the speaker and not to hdmi from the nvidia card ?

1 Like

Aight aight, Plexamp working with a simple re-install, ohweeeee :partying_face:

1 Like

You mean in the Zorin OS audio settings? Most definitely!

1 Like

Sometimes when i connect my ps4 controller for some reason my sound change to the sound from the ps4 controller :joy:

Haha yeah I totally see your point, but other programs are playing audio at the same time. But could it be possible that only specific apps use the wrong audio device? :thinking:

Trying to install Telegram with

sudo snap install telegram-desktop --edge

now, let's see :crossed_fingers:

So, it's getting weirder and weirder. As soon as I play a media file within Telegram (Video or a voice mail), Telegram and the other apps (Whatsapp, Plexamp) stop playing audio :sweat_smile: What the heck?

Also, if I click on "play" on a media file in Telegram, instantly my video stops playing, displaying a transcoder error :thinking: :thinking: :thinking: What the actual heck is going on? :sweat_smile:

What audio system do you use ? Is is stereo or dolby ? hdmi cable or ?

@Aravisian maybe split the threat ?

1 Like

Good point! I'm tinkering with the audio settings as well and mayyybe you can help. Also think splitting the threads might be good.

However: A few months back I tried to connect my shure microfone to the computer, which didn't work with Zorin's default pulse, so I installed pipewire as a workaround. Maybe this causes issues now with the Nvidia card/the changed setup?

Let me see if I can revert back to the default pulse audio and test

I have not been following along and am multi-tasking; If you could, please note which post should define the Split Point...

EDIT: TY Carmar...

Ooookay. After reverting back to default pulse, zorins settings app hung up, forcing me to hard reboot, now neither of my 3 monitors is displaying anything :tada: zorin boots and is stuck on the zorin logo, even though the system is booted :slightly_smiling_face:


Try grub and recovery mode ???

1 Like

Same Kernel panic error message as yesterday when trying to enter recovery mode. Oh boy...

If it was my computer ... I would start over from scratch.


Probably the best thing I can do here, true

Never asked, but do you have a separate soundcard? (And I don't mean on-board sound.)