Virtual Box Kernal driver missing

Here is the information:
Failed to open a session for the virtual machine Puppy linux.

The virtual machine 'Puppy linux' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}

I tried reinstalling it and new Kernal system's but nothing worked.
Please help.

System info:
Memory 11.6 GiB
Processor: Intel® Core™ i5-6500 CPU @ 3.20GHz × 4
Graphics card (I have two!) : AMD® Cedar / Mesa Intel® HD Graphics 530 (SKL GT2)

Disk Compacity: 1TB

Zorin OS 16.3 64-bit X11

does this happen to your other virtual machines too? did you upgrade the kernel? it's most likely the kernel issue, try booting into the older kernel version. when booting press advanced options for zorin then select the older kernel.

I booted into all of my old kernel's and it still didn't work.
BUT, I did upgrade the kernel twice!

Kernel 6.0.9 and 6.6.1

All my VM's...

Did you download the .iso from here?

Did you download the 'Ubuntu Focal 64' image?

I now prefer using virt-manager over Virtual Box. The iso of Puppy Linux uses kernel 5.4 and I got it running in virt-manager on KDE Neon which uses 6.1 kernel:

Were these signed or unsigned kernels?

Yes, but I was also trying to use a windows vm

unsigned. But I tried using my signed ones but it didn't work.

I would follow up on or double check this or try using the TuxInvader kernel as it is signed.

The symptom strongly suggests an unsigned kernel - it would be my first suspect.

I wasn't here for a while...

I used mainline to install my kernels.

I got Virt-manager installed and working but it uses a LOT more memory.

Strange - I have got a VM of Zorin Core running in virt-manager, nothing running or installed in Oracle Virtual Box and VB is using more memory than virt-manager:

Also, Virtual Box failed to enumerat USB ports!

And now I get an error message:

VM Name: Zorin 16.3 Core

VirtualBox can't enable the AMD-V extension. Please disable the KVM kernel extension, recompile your kernel and reboot (VERR_SVM_IN_USE).
Result Code:
IConsole {6ac83d89-6ee7-4e33-8ae6-b257b2e81be8}

virt-manager is so much easier and better graphically.

I got KVM working, and it works for what I need.
But however, some of the drivers for that are also disappearing.
I'm thinking it's a kernel update bug, but I can't find it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.