VirtualBox 6.1 does not work properly with Zorin Linux with ease

There is a problem in that the Software Store has available VitualBox 6.1.22 only and this does not work properly with the way it currently installs via the software store. On checking this with my son who does a lot of work VirtualBox the problem arises from changes to VirtualBox in vs 6.1. making it not fully compatible. The follow quotes are from the VirtualBox website:

Download page: "Please also use version 6.0 if you need to run VMs with software virtualization, as this has been discontinued in 6.1. Version 6.0 will remain supported until July 2020. "

Manual page - Chapter 2.3.2.1 Kernel Modeules and UEFI Secure Boot: If you are running on a system using UEFI (Unified Extensible Firmware Interface) Secure Boot, you may need to sign the following kernel modules before you can load them:

** vboxdrv*
** vboxnetadp*
** vboxnetflt*
** vboxpci*

See your system documentation for details of the kernel module signing process.

Since most modern systems now use UEFI and this needs to be done to use VirtualBox 6.1 it's crazy to expect the average user to do what's needed to do the required changes to those modules.

This needs to be brought to the attention of the developers so the Software Store can be changed back to using VirtualBox 6.0 or the installation code for installing VirtualBox amended to have the Software Store installation process for VirtualBox 6.1 do the required module signing for the user as part of the installation.

I'm currently running Zorin OS 16.

I'm not sure how to bring this to the attention of the developers, nor how to safely manage a work around for myself as I tried downloading VirtualBox 6.0 from the website and ran into other problems getting it to run 32 bit Win XP on my system. have fallen back to running Wine to play Diablo II LoD but the 800 x600 window on my 42 inch 3,840 s 2,160 monitor is damn small and annoying. Can't play for long due to the eyestrain on these old eyes.

VirtualBox does not work with Secure Boot enabled.

As you already downloaded and installed V.B. 6.0 and had problems with it as well, I would have no reason to expect the Software Store to handle V.B. 6.0 any better. Software Store is an Ubuntu application and VirtualBox is... Oracle... Both of which are not under the control of ZorinGroup.
And Oracle is not even under Oracles control.
I just do not believe contacting Oracle will have any benefit.

The problem with signing the modules is that everytime the kernel updates, you will need to re-perform the procedure and resign the modules.

I searched around a while to find a good and reliable guide that you can reference for signing the modules and settled on this one:

Looking at Alternatives to VirtualBox, the list usually includes VMWare and Parallels Desktop, both of which are pay-for apps; but there is also QEMU, which I have never tried and cannot vouch for but has good reviews:
https://download.qemu.org/qemu-6.1.0-rc3.tar.xz

Thanks for the response Aravisian. My son did the download direct from the VirtualBox website and he had issues with getting VirtualBox to talk nice to the Zorin OS due to it downloading and installing outside of the usual package manager process; I got the impression some of the triggers didn;t go where the system wanted them and that caused issues. I don't really understand the virtual machine stuff and didn't understand what he said the issue was.

However, looking at what is on the VirtualBox website and what he said, I got the impression that if the 4 listed modules are 'signed' with the proper permissions then it will work, but for me to do that I have do some command line interface work of some sort I don't fully understand and then restart the system. I got the impression that it's simply a matter of giving the modules the right access permission which aren't given to them when it installs, which seems the best time to do that.

Alternatively, having VirtualBox 6.0 available for download and install via the Software Store should resolve the issue my son hit. Anyway, past my bed time here, so have a good day or night, catch you later.

I typed a very long post explaining how all the process works and as I was doing so, I ran the installation through terminal just to test what would happen.

Sure enough, this is what happened:
vboxdrv.ko:
Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/5.11.0-25-generic/updates/

vboxnetadp.ko:
Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/5.11.0-25-generic/updates/

vboxnetflt.ko:
Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/5.11.0-25-generic/updates/

It DID install the later version, but it also DID sign the modules.

Please open your terminal and run the following commands:

sudo apt remove --purge virtualbox

This is to remove any old stuff
Then install:

sudo apt install virtualbox

That should get you set up.

Well, I've done that, but VirtualBox still won't work properly. I'll copy the terminal window so you can see what those 2 commands did:

ernest@ernest-MS-7C37:~$ sudo apt remove --purge virtualbox
[sudo] password for ernest:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libgsoap-2.8.91 liblzf1 libqt5opengl5 virtualbox-dkms
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
virtualbox* virtualbox-qt*
0 to upgrade, 0 to newly install, 2 to remove and 0 not to upgrade.
After this operation, 172 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 308337 files and directories currently installed.)
Removing virtualbox-qt (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Removing virtualbox (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
(Reading database ... 307972 files and directories currently installed.)
Purging configuration files for virtualbox (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Processing triggers for systemd (245.4-4ubuntu3.11) ...
ernest@ernest-MS-7C37:~$ sudo apt install virtualbox
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
virtualbox-qt
Suggested packages:
vde2 virtualbox-guest-additions-iso
The following NEW packages will be installed:
virtualbox virtualbox-qt
0 to upgrade, 2 to newly install, 0 to remove and 0 not to upgrade.
Need to get 0 B/43.2 MB of archives.
After this operation, 172 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package virtualbox.
(Reading database ... 307970 files and directories currently installed.)
Preparing to unpack .../virtualbox_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb ...
Unpacking virtualbox (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Selecting previously unselected package virtualbox-qt.
Preparing to unpack .../virtualbox-qt_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb ..
.
Unpacking virtualbox-qt (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Setting up virtualbox (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Setting up virtualbox-qt (6.1.22-dfsg-2~ubuntu1.20.04.1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for systemd (245.4-4ubuntu3.11) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for shared-mime-info (1.15-1) ...
ernest@ernest-MS-7C37:~$

I then opened VirtualBox and tried to create the 'machine' to run Diablo II LoD in Win XP and get it working so i checked the settings where it had the error: Invalid settings detected:

System: Acceleration page:
The hardware acceleration is enabled in the Acceleration section of the System page although it is not supported by the host system. It should be disabled in order to start the virtual system.

When I go to that setting there's a check box in the middle of a line:

Hardware Virtualization: Enable Nested Paging.

based on that error message unchecking that box should make the error go away, but the error stays and I can't save the machine to use it. result = no working VirtualBox.

I hope this extra information helps someone to understand what's wrong and how to fix it.

Now to go back to bed and I should learn not to check messages when I get up for a fluid adjustment during the night.

The DKMS is the important part- running sudo apt autoremove would have removed that.
You can try the same:

sudo apt remove --purge virtualbox virtualbox-*

sudo apt autoremove

Make sure it is ALL gone, otherwise the installer will skip the installation of the parts it thinks are already in place.
Next, I will add a step, to see that your kernel is up to date:

sudo apt update && sudo apt full-upgrade

Then:

sudo apt install virtualbox

Just woke up and did as you said, but still have the same problem in that VirtualBox settings shows the System: Acceleration page error and won't save the settings, thus not able to run the machine. I'm beginning to think the problem is much deeper than it seems at first. Whatever the root cause is, it's way beyond my meagre talents, so the average user would be lost as well.

This is a different error than the initial one in the O.P., though.
Do you have virtualization enabled in your computers EFI settings? This is not part of the Operating System, but part of the Motherboard 's OS. To access it, you would need to hit F10 or similar at the boot up splash screen.

I'll have to get back to you on that as I'm about to go out, then I have to close down and check that out. Wouldn't that affect Wine as well? Wine works but isn't as good as VirtualBox as the screen is so dang small.

I had wondered about increasing the size of the Wine Window- but I do not know much about it.
Wine is not an emulator or virtualization software - it uses existing hardware and software on your computer to adapt to make a Windows application run.

two points here.

  1. I did increase the Wine window before, but the displayed size of the game was still only 800 x 600 and required squinting as I don't want to adjust the resolution just for that.

  2. back from the doc. and checked the BIOS - the system says: Safe Virtual Machine - Yes - - however, I couldn't find any place where I could change the SVM setting nor did the section on the CPU data didn't allow me to change that setting. So I'm at a loss as to where o go at the moment.

I guess this goes into the too hard basket and put aside for now. Is there a special tag I need to activate to do that?

Not sure about a forum tag, but let's tag this to @azorin and @zorink to examine when available in order to consider the Software Store side of VirtualBox not installing with signed modules, but the terminal installation does do it.
There may be a solution for that. Synaptic may install it properly, I am not sure. I have already installed VirtualBox three times in the course of the thread for testing and I'd rather not do another one :smiley:

I also have struggled with getting VirtualBox to work. To the point of throwing in the towel, even. I certainly understand your frustration. There are days when it seems like solving one problem only leads to the next one it surprises you with.

OK. Now how do I do that as I'm not familiar with how this forum software works and nothing jumps o0ut at me as to how to do that?

Sorry, I was not very clear about that... When I posted that, the @ signs in front of their User ID's tagged them to give them notification of this thread. So, it has already been done.

Thanks