VirtualBox vm's no longer have vm control menu at top of screen (ZorinOS 17)

I use VirtualBox vm's every day. They occasionally freeze. It is usually easy to un-freeze them by selecting 'Reset' from the 'Machine' menu located in the menu bar at the top of the vm window. I recently upgraded to Zorin OS 17 Pro. I believe I gained a newer version of VirtualBox with the OS upgrade. I cannot find any way to show this menu again. I do not know why it disappeared. I need to be able to reset rather than kill and restart the vm's. I looked through the 8 billion posts about VirtualBox to no avail. Thanks in advance.

Later that same day:
I have just discovered that some of my vm windows still show the menu, while others do not. They are all using the same version of VirtualBox. So it has to be a setting somewhere. I have repeatedly dug through all of the setting in the vm manager app as well as those of the vm itself.

Hi JimH Deldoy here I had the same with the last Zorin update you used to be able to get the menu by right clicking on the area where it should be and select show or hide but this also is not working.
I assume that you know that it is available in full screen and seamless modes you can switch this whilst running without problems

Hi it's Delboy again I was playing around with the problem and cured it on my PC what I did was to press Host+C let it change then press Host+C again up came the menu hope it works for you

Thanks, delboy. I'm not sure which key you mean by Host. I have a Win button. I tried Win+C, but nothing happened. I also tried going full screen, but the menu did not appear. I'm on Zorin OS 17 and VirtualBox says that it is 6.1.

Sorry have not been around to answer before now Host key is Right Control if you press right control +f you will go into full screen mode and provided you haven't altered the default settings the bar will appear if you hover the mouse at the bottom of the screen

You don't say what version you are working with you say 6.1.(what ) in the virtualbox [about virtualbox] at the bottom it will tell you I'm running 6.1.50

Thanks to you, I learned about the Host+Home shortcut to show a popup menu with the same sub-menus as the disappeared menu bar. That was the secret that I needed. The popup has a View sub-menu. I found an option to display the menu bar there. Problem solved. I still don't know why it disappeared in the first place, but I'll accept reality as it now presents.

Jim, can your last post #7 be marked as :ballot_box_with_check:Solution, if true?

Unfortunately, it is not resolved. I have searched and searched for a solution with no success. The menu is enabled in the vm settings. My 5 other regularly used vm's all have the menu showing. It is only one that does not. It hosts my web yahoo email on firefox. Replacing this vm would be a real pain given the loss of cookies. The current crop of captcha images is so blurred that I cannot succeed in passing the test.

OK, first off, backup all your crucial VM's to another location. Next, install virt-manager (Virtual Machine Manager). Always been superior in my eyes to Virtual Box, particularly with regard to USB 3.0 support, and the Desktops of VMs look more like a clean 'bare metal' install - but don't use for gaming!
virt-manager allows you to import VB vhd's and converts them into qcow2 images.