VLC Flashing During Playback


When playing videos on VLC, the screen flashes constantly, making it impossible to see what's going on.

I am accustomed to VLC and very much want to keep using it on Zorin. The built-in player isn't really as good in my opinion.

I'm on a fresh install of Zorin, as of a week or so ago.

The only thing I've tried is this:

(sudo apt install ubuntu-restricted-extras)

VLC also often stops playing at all, but the icon is shown in the 'sys tray', bottom right.

Any ideas please?

Did you install VLC from the Software Store? If so, you have a dropdown menu to choose the source of the installation where you have the option to choose between Flathub and ZorinOS. Make sure you use the ZorinOS one.

If you are not sure, open a terminal window (search for "terminal" in the applications) and run the following:

flatpak list

If you see VLC listed in there, remove it:

flatpak remove org.videolan.VLC

Than, you can proceed to re-install but choosing the ZorinOS format instead. Hopefully this will do the trick.


Not sure if required, but did you reboot in between down loading Extras and using?Can always try to re-download it in case there was an error with either the download or accepting the EULA license.

If VLC is installed as Flatpak then it won't be able to use those codecs which is what I think is causing the issue. But rebooting is always a surprisingly good idea even to this day :smiley:

Might help out; I stopped using VLC myself..

Grab zorin-os-restricted-addons and zorin-os-restricted-extras (done) - includes codecs for audio / video. Before those were installed, Videos wouldn't play MP4's correctly.

You could also try installing the latest VNC via their repo:

sudo add-apt-repository ppa:videolan/master-daily
sudo apt-get update
sudo apt install vlc

Shouldn't be an issue for codecs after that :grin:

1 Like

I also had playback issues in VLC in the beginning. Videos are laggy, grey & green pixels were showing while playing vidoes.

I solved this by Disabling the Hardware-accelerated decoding and everything works fine for me. Haven't faced any issue in VLC after that

Open VLC
Tools>Preferences>Input / Codecs

I don't know if this gonna work for you or not.
Just give it a try :v:


Sorry for the late reply! When I last came on to this site, it seems it was having technical difficulties. This solution seems to have worked for me. It seems odd that Zorin doesn't use this option as default?

Yeah... it's complicated. There are pros and cons to both options but long story short: I'd recommend to install the .deb package format whenever possible (this is what appears as "ZorinOS" in the Software Store), as it's the native format for Debian-based distributions. If that's not an option then use Flatpak.

1 Like

Yep I've had nothing but trouble with flatpacks. The sandboxing seems to be a real problem. How would I install VLC outside of the software centre please? It's really confusing, all the options! Thank you.

1 Like

Easiest way is through the terminal:

sudo apt install vlc

If you prefer a graphical interface other than the preinstalled Software Store, I'd recommend using something called Synaptic Package Manager. You can use it for managing all your packages but only those that are .deb, no flatpaks or snaps (snap packages are similar to flatpaks).
You can install this one from the Software Store as well as through the terminal:

sudo apt install synaptic
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.