Volume control seems faulty in Zorin 17

Going from Zorin 16 to 17 and the System Volume control seems to have stopped functioning the way you would expect. If you move the slider all the way to the left then it mutes the sound but if you move it to the right there is no gradient to the increase in sound. It get louder as it unmutes but then it stays the same all the way to 100%. If I turn on over amplification then it gets louder after 100% but this isn't the way it worked in 16.

Is this a glitch or just me?

The mixer beneath still works with a gradiated volume increase on individual components.

In terminal type:


Can you check in alsamixer that the sound channel volume sliders there work as expected.

I would not expect Wayland instead on Xorg session to mess with volume control, but you could also try a fresh login session using Xorg instead of Wayland to test that.

I'm not on Wayland, I'm using Xorg.

So if the volume mixer in alsamixer isn't changing the volume either, what does that mean?

These both have no effect on the output level.

That alsamixer screen looks abnormal.
Can you hit F5 to show All sound channels and post screenshot.

Do you know what soundcard/s you have, which worked before.
Is your sound card a USB device?

In alsamixer, hit F6 to list/select soundcards.
Are any other soundcards listed. If yes, select the alternative and see what channels appear with that.

Was that transition from Z16 to Z17 done using the Zorin Upgrader?
If true, I'm wondering if something got missed in that process.

I upgraded to 17 when i messed up 16 by playing about with VM's - doesn't matter really.

I formatted the partition and did a fresh install of 17, I restored my files from a backup.
So whatever is wrong came from the fresh install not the upgrade.

Here's the two images

I'm using a Behringer UCA222 USB Soundcard which connects to my speakers with an optical cable.

I wanted optical output as was getting distortion from bluetooth and onboard sound didn't have the right outputs for my audio device. It supports HDMI sound but it kept messing-up the picture so this device has been flawless since I got it.

OK. So you have started from fresh install of Z17, so can now discount upgrader issues.
Have you checked for software and driver updates after installation?

In Zorin Settings>Sound
Which soundcard appears there? Is it your USB soundcard?

I know it is probably the first place people look, but have you seen this: Set Up Sound - Zorin Help

Done a websearch of "Behringer UCA222 USB Soundcard Ubuntu 22.04" found this old [Solved] item. I don't know if that may still help you.

Another thing I register from your OP is that this all worked on Z16, but not on Z17. So wondering if it is a linux kernel regression and just need to boot an older one from grub menu item "Advanced Options for Zorin".

Sorry, but sound issues are a headache with too many variables. It is often a case of stumbling on something or playing with settings to arrive at a solution.

@Aravisian . any ideas. Zab

EDIT: From alsamixer F6 to list/select soundcards.
What happens if you select [default:2 HD-Audio Generic] ?

Re Behringer UCA222
EDIT2: Just found this: Behringer UCA-222 (and UCA-202) under Linux
EDIT3: and: The Behringer UCA202 (UCA222) USB Audio Interface On Linux - Larry Talks Tech

Thanks for the help, btw.

I keep going away and coming back to this.

So the sound works, thats never been the issue. It's just the master volume not working the way it should.

I booted into the UEFI and turned off the onboard sound in case that was confusing things.
It had no effect.

Looking at the alsamixer it has the Nvidia card as primary default sound device and I can't seem to change that. I changed the sound output in the Sound Panel to the Nvidia HDMI and the volume gradient works properly if I use that device. Therefore I think a setting is confused/wrong somewhere. I'll go see if there's anything in those Behringer links you posted.

Now I have no sound in xorg, but sound works on Wayland and cinnamon.
On the last boot I couldn't choose it took me straight into Wayland so I reinstalled xorg with sudo apt install zorin-os-desktop
now I can choose the DE on reboot again.

Zorin 17.1 Pro seems kinda buggy to me.
I'll look again tomorrow

Further Edit:
Got sound back. I had changed the default in /etc/asound.conf and forgot. :see_no_evil:

Here pactl shows I have USB as default device.

amixer shows this - not sure which is which here
amixer controls

so I tried this...

but it's not changed anything

none of these seem to make a difference either.
If I try to make the first figure anything other than 1 I get an error see below

this is what I have in /etc/asound.conf now
latest ect asound

I had pcm.device as 1 and that disabled the usb sound so put it back to 0
but pcm.card seems to make no difference as 1 or 0

So Master volume still won't change the volume between 1% and 100%, it mutes at 0% and it works in over-amplification.

1 Like