Wallpaper doesn't stay after reboot

Hello

For some reason, each time I set my wallpaper, then reboot, it has reverted back to the same (a different) one each time.

Does anyone have any suggestions please?

Thank you!

Please tell us what version of Zorin you are using .

Zorin OS 16.2 (Core, not pro)
64-bit

Is the background image you are using stored on a separate drive from the one Zorin OS is installed on?

1 Like

It was! I think that may have fixed it and also ties in to another ongoing issue I have, with my hard drive:

Thank you!

1 Like

This hasn't fixed it unfortunately. I'm using a wallpaper that now lives in my Documents folder, but restarting still reverts it :frowning:

Try moving the image to /usr/share/pixmaps or to /usr/share/backgrounds
It may be a permissions issue.

You can use GUI if you prefer:

sudo -i

nautilus

In the elevated file manager, just drag and drop to move the file.
To reach Root in Roundabout Nautilus... In the left pane click Other locations. Then in the right pane, click computer
Then you will see the root directory.

I've done that, but it has still reverted at restart :frowning:

Whilst I have you; I found this whilst navigating those folders. It looks like there's some way to have these wallpapers cycle throughout the day / night, but I've never seen such an option. Do you have any idea how to enable this please?

Not that I know much, but I had been playing with my backgrounds previously. Do you have any user installed backgrounds in this folder? You will possibly need to select the "Show Hidden Files" from the Hamburger menu of Nautilus

/home/xxxxxxxxx/.local/share/backgrounds

It might be interesting to know where you may have background images placed. You can open Files, go to Other Locations and select Computer or what ever your boot drive is named and then do a search on the entire drive for one of the background images.

Had... I stepped away right before you posted that, it seems.:wink:
That option is a Gnome Extension and I do not use Gnome. I run on Zorin OS Lite.
But yes, I know of that feature... perhaps a Gnome Expert can say where to find it in settings.
@Storm @Michel @...whoever else uses Gnome...

Another point... Are the background images an unusual Size or Format?

1 Like

That's a timed wallpaper. It changes according to time of day. Select the one with the clock icon on the lower right in the Settings > Background dialog. See the image, red arrow.

2 Likes

No, no unusual sizes or anything. I've tested this some more and found it also happens for the wallpapers that come as part of Zorin, so it is making even less sense now. So annoying.

Can you try disabling all extensions except for the most essential ones (like app menu can stay) and then testing the wallpaper?

I solved it (accidentally)!

I was messing with startup apps and came across this; no idea what it is, but removing it has fixed the issue. Seems it was overriding my wallpaper at boot.

Thank you all so much for your time helping me. Massively appreciated!

1 Like