Want to disable GNU Grub Menu options

Hi when I start zorin os I get a GNU Grub menu option and then I select the first options after that some sets of script running and then my login page opens.
But I want that I don't get these grub menu option and all. When I open zorin os directly zorin logo animation on start-up and then login page will open. Anyone could you please help me with that. I have attested the image below.

In terminal, please run

sudo nano /etc/default/grub

Copy and paste into this thread the contents for the following lines:


This is what the settings should look like for your preference to be met:


I got this options when I hit first command. What to do here and how?

Ok I did this then when I restart that certain sets of scripts are now disabled that zorin logo is coming but on startup that blue screen🟦 is still appearing want to disable that also. How to do that.
And also when I poweroff, that set of instructions are running then after tha it goes shut down. Is any other way to disable that also.


My mind just blew. The screen you show is... Not the Default for Zorin OS.
Have you used Grub Customizer?

No it's just theme changed that's it only

The file is blank. That cannot be.

That's what I was also thinking. But I have added the command that you have shared and saved by ctrl + s and then runned the command that update grub one.
See the 2nd comments what I get after this

Please post a screenshot of that...

See this when I hit the first command and hit enter this text is automatic populated that I have pasted earlier.

That alone is missing the Grub Distributor and Grub Theme - and it was blank prior though you were able to boot.
What this tells me is that your system is modified quite significantly from the Default Zorin OS. I would not begin to know how to help you troubleshoot issues without a lengthy detailed list as to how you made the changes.

If you have made no changes - Then you are operating with a likely Non-Zorin supplied copy of Zorin OS. IF so, where did you download from?

It is after 2am here and I must be up early - so this is my last post for a few hours as I try to get much needed sleep.

One other possibility I just thought of is you May Be booting from a LiveUSB with persistent boot... is that the case?

Ok actually I was trying to modify some grub yesterday don't what exactly I did like I had refered various forums.
I have downloaded the zorin os lite version from zorin platform itself.
Could you please help me with that by getting default configuration.
I know you were feeling sleepy. But please check into this again once you feel fresh.

1 Like
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Here is default Grub file. Now, I am off:P

1 Like

Reply to edit:
I don't know earlier when I poweron the laptop I am getting that enter zorin advance zorin options and all
But from yesterday I am getting this blue screen mode options.
After running the above command I am not getting now that running script page instead of that I am getting that zorin animation logo page. But that blue page options is still persist.
And also when I poweroff that certain running script shows then it went to shut down.

Ok thanks will try to update this into my grub.
Edit: Finally updated the grub and the system now works fine.
Instead of that blue page now I am getting that enter zorin, advance zorin uefi firmware settings and then when i click on zorin then that zorin logo comes and that poweroff options are also working fine. Thanks buddy :slight_smile: You helps me a lot as I was trying from yesterday itself :slight_smile:

1 Like

Is there any possibility that I didn't want to get that enter zorin, advance zorin settings, uefi firmware settings GRUB Menu. Rather directly open that zorin logo without I have to select zorin options. As I have only zorin os installed.

Is Grub Menu set to hidden?
IF so and you are still seeing the grub menu, please run


in terminal and post the result

ootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0006,0001,0002,0003
Boot0000* ubuntu
Boot0001* UEFI:CD/DVD Drive
Boot0002* UEFI:Removable Device
Boot0003* UEFI:Network Device
Boot0006* UEFI: TOSHIBA MQ01ABD100, Partition 1

This I am getting

This may be a recovery partition that was placed by the manufacturer. I do not see any other OS listed, however. The grub menu will appear if you have another OS in order to allow the option to choose which one to boot.

Let's edit grub again...

sudo nano /etc/default/grub

Add this line at the bottom:


Tap ctrl+o to overwrite the file, then enter key to save current configuration. Tap ctrl+x to exit the editor.

sudo update-grub

Still I am getting same grub menu option on startup