Warp terminal worked with u in zorin?

warp terminal , it was for mac only, these days they released version for linux.
my question i want to know why it can't run with me, i asked about that in their site, but some told me that your system is old. it works with u in zorin?

i agree with u, i only wanted to know, it works in zorin or not. if it worked with any zorin's user, then it will be problem in my hardware device, not the system. also i'm using zorin16 which it's based on ubuntu 20.04, but zorin 17 based on ubuntu 22.04, who replay on me in their site told me i'm using old system, anyway that the details about that:

I get similar errors on both Z16 and Z17. But I would hardly consider this a problem with the system... it's a terminal, these things exist since the 80's... even the AppImage which is supposed to contain all dependencies needed to run, doesn't work.

Note that Warp Terminal is proprietary software, and we can't see what code is actually running in your machine, and there's also no mention as to the minimum requirements. Use at your own risk.

2 Likes

I use Warp Terminal on Zorin without any issues at all. Do you know you must sign in via website to login and use the terminal?

I must login to her Website to use the Terminal that I have installed on my System? I cannot simply start it?

That is correct. See here. Warp Dev Troubleshooting Scroll down to How to get an Auth token to login

1 Like

no, i don't think that , i tried that, and i still has the same problem. u used it on zorin 17 or zorin 16? i think it's problem related to display card

Ha, interesting.

1 Like

I using it on 17 Pro. Sorry I can't help further.

That is really strange... I guess it's because they need want to keep track of who's using it at any given time, and how, given the AI component?

But in any case, for me that wasn't the issue. When I tried to launch it simply froze the window without doing anything (on both the ZorinOS 16 and 17 - Core). I tried on a virtual machine so that may have something to do with it too.

Xorg, on both versions of ZorinOS. If there's need for dedicated graphics card I suspect that may be the problem.

the problem with me that it doesn't launch , if it launch with u but u have crashing problem, there is new version solved the crashing , u can try it https://releases.warp.dev/stable/v0.2024.02.27.08.01.stable_00/warp-terminal_0.2024.02.27.08.01.stable.00_amd64.deb

That's all right thank you, not really interested in installing this again :smiley:

EDIT: It seems that there are plans to eventually open source the project, according to this article. So I will definitely take a look at this when that happens:

1 Like

I stick to ZSH with powerlevel10k - All open source, no logging in required and all the sweet features I prefer to have.

1 Like

I also prefer it that way; simple is usually better. Having to log in online to run a terminal emulator is a massive red flag for me. But hopefully they'll make this right once they make it open source, if they every do.

Everyone seems to like ZSH but I haven't tried it yet as I'm quite comfortable with Bash. And as for the terminal itself I'm currently trying Alacritty because of the single file configuration; this makes it easy to share, update, backup and restore as needed.

1 Like

i don't think i will use in the activates of installing ,updating ,upgrading etc, i will use the normal terminal for that.
but i think that terminal will be very good for learning linux commands, and will encourage the bignner or windows user who come to linux to be happy to work with linux commands line, instead of searching about command to do something, i can know that in the terminal without any annoying or searching time

1 Like

i agree with u. i like the idea of command line ai, but the privacy and trust are first.
there is a lot of projects that allow that features of using ai to help in write commands, may be safe and trust, the famous one is the GitHub copilot , and there are terminal copilot projects that use ChatGPT in terminal for that, there are paid. and there is ilama-terminal-completion, i think it free but need a lot of space to install it locally

1 Like

I have dropped Warp Terminal as I found it to be quite the resource hog and would slow down my system so until they fix that I'm saying byeeeeeeeee

2 Likes

I tried aichat , it is Amazing, I used it with Gemini(The Gemini from Google AI Studio is free, with a rate limit (60 QPM)