Waydroid: problems with Location Services

Hi,
I am running Zorin 17.1 on an HP Zbook15 laptop. (I love Zrin OS by the way, thank you so much to all those who make it happen).

Yesterday I installed Waydroid, as I don't have a smartphone but I want to use Facebook Dating, which is a smartphone-only app.

The installation (GAPPS version) appeared to go well and I have successfully installed a few apps inc Facebook. The normal Facebook appears to be working fine in Waydroid.

I have also managed to get Location in Settings saying that Facebook has access to Location (after initially having problems with this).

However the Facebook Dating initialization still gets stuck on the Location pane.
It says "Something went wrong. Please try again" when the application tries to access location (see image)

I understand that people on here are unlikely to have an intimate knowledge of the Facebook Dating app and its usability in Waydroid, but what you might be able to help with is: how can I debug what is going wrong here in a way that might identify what the problem is and how I can fix it? Thank you

Did you activate the Location Service in the Settings? When You go to Privacy and there to the Location Service, you find a Toggle to turn it on:

1 Like

Thanks for your reply. Yes, I have turned on Location Service (it's not called precisely that in this version but it's definitely switched on in Settings)

Okay. Hmm ... Maybe this isn't supported? Or Waydroid, this App and the Location Settings are not working good together?

I think perhaps the Waydroid app is looking for GPS information from the virtual Android phone. But, the laptop does not have a GPS receiver installed. Consequently, there is no way for the Waydroid virtual phone to know its location. Zorin gets its location from the ISP which is not the same thing. Again, this is a possibility. I have no experience with Waydroid.

2 Likes

That sounds likely.
I guess there must be a way to pass "GPS information" to the Waydroid app - even if it is set manually, by entering coordinates or whatever.
I guess some people would want to use this to disguise their real location but ironically, all i want to do is pass over my actual real location because I want the dating app to show potential matches in my area!

Might be useful to check the firewall report section to see if a specific port is being blocked or change the incoming and outgoing choices. If changing them doesn't change anything please restore the default state (Incoming: Deny and Outgoing: Allow, displayed whenever the firewall utility is launched by the way).

This is really helpful, thank you.

1 Like

There is an opened issue about this, so it may be related. Someone there shared a possible workaround that you can try:

I think this would work if the host device (the laptop) has a GPS receiver. If there is no GPS receiver to compute the location there is nothing to pass on to Waydroid to allow navigation.

I haven't solved this issue yet, but of interest is that I have solved another related problem, of passing Location information on to websites using the Chromium browser - in a similar example to the above if using a dating site's web page (as opposed to smartphone app) it's a common problem that the browser gets location info from the router which is inaccurate and often just gives the capital city, for example, of the country you're in.

I had tried to manually change this in Chromium via Developer Settings -> Sensors and entering lat / long coordinates there but that didn't work. Then I tried installing the Location Guard extension an that did work in Chromium.

So, I can now get dating web sites to succesfully detect my location when using Chromium browser (one could of course manipulate this to give any location in the world, but for once anonymity has gone out the window and I want these sites to recognise my true location!). Still need to solve achieving this within Waydroid. There are a few addons and extensions I could try which seem to be marketed at people looking to use to disguise their real location - which are mentioned in the link posted by @zenzen above - but i haven't yet managed to get any of them to work.