Wayland session issue - can only use X11 session currently [Zorin 17 Pro]

Well, I'm back again already with a new problem!

I have been using ZorinOS and not had any more issues, and then today randomly I opened the 'About' section in settings. I noticed it said X11 instead of Wayland.

Logged out, chose Wayland from the cog (which already had a dot next to it by the way) and logged in. Didn't do anything other than take me back to the login screen.

Does this every time, unless I select the X11 session in which case I get to the desktop fine.

Any ideas as to whats causing this? One thing I did do recently was update the kernel, and is the only thing I can think of that may have affected things. But then I don't know if it had X11 after the initial install of ZorinOS - Wayland is default now on Zorin so I assume that would not be the case.

HWE enabled kernel version 6.5.0-14 is the kernel I installed if that helps.

Note: The cog doesn't appear on first boot, but does when I log out of the session and then click on my username. (Not there on first boot, even when clicking username.)

About section in Gnome preferences:



Results of /cat/etc/gdm3/custom.conf:

# GDM configuration storage
# See /usr/share/gdm/gdm.schemas for a list of available options.

# Uncomment the line below to force the login screen to use Xorg

# Enabling automatic login
#  AutomaticLoginEnable = true
#  AutomaticLogin = user1

# Enabling timed login
#  TimedLoginEnable = true
#  TimedLogin = user1
#  TimedLoginDelay = 10




# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes

Result of attempting to run a wayland specific terminal app from command line:

info: main.c:420: version: 1.11.0 -pgo +ime -graphemes -assertions
info: main.c:427: arch: Linux x86_64/64-bit
info: main.c:439: locale: en_GB.UTF-8
warn: config.c:2928: no configuration found, using defaults
info: fcft.c:314: fcft: 3.0.1 +graphemes -runs -assertions
info: fcft.c:324: fontconfig: 2.13.1
info: fcft.c:330: freetype: 2.11.1
info: fcft.c:794: /usr/share/fonts/truetype/croscore/Cousine-Regular.ttf: size=8.00pt/8px, dpi=75.00
 err: wayland.c:1211: failed to connect to wayland; no compositor running?
info: main.c:670: goodbye

Any help would be much appreciated.

Could take a look at this thread and see if it helps? Try first by creating a separate user account from Settings -> Users, and log in through Wayland on that account. If it works, it may not be the kernel itself but something in your configuration. Although, it's not clear what that may be.

I'll certainly try that - was just about to do the nuclear option and reinstall but would rather avoid if possible.

Some investigation of my own has uncovered the culprit (I think).

Looking at journalctl -b, I started getting messages a couple of days ago regarding a directory in /tmp not being writable and XWayland not starting because of it. This is repeated each time I've booted since.

gnome-shell[1381]: Running GNOME Shell (using mutter 43.8) as a Wayland display server
gnome-shell[1381]: Failed to start X Wayland: Directory "/tmp/.X11-unix" is not writable
systemd[1914]: Starting GNOME Shell on Wayland...
systemd[1914]: org.gnome.Shell@wayland.service: Skipped due to 'exec-condition'.
systemd[1914]: Condition check resulted in GNOME Shell on Wayland being skipped.

So, just now I changed the owner on that folder to root, logged out and back in again and found myself in a Wayland session. After reboot however, the problem returned and I am now back in X11.

Looking at that error online took me to a RedHat page which mentioned a bug with systemd - something about it not creating tmpfiles properly before mounting the directories. Obviously not the same issue, but definitely on a similar vein.

Permission showing in /tmp:

-r--r--r--  1 gdm   gdm     11 Jan 13 11:22 .X1024-lock
drwxrwxrwt  2 gdm   gdm   4.0K Jan 13 11:22 .X11-unix
total 8.0K

Permissions inside the .X11-unix folder:

drwxrwxrwt  2 gdm       gdm       4.0K Jan 13 11:22 .
drwxrwxrwt 17 root      root      4.0K Jan 13 11:27 ..
srwxrwxrwx  1 wheeljack wheeljack    0 Jan 13 11:22 X1
srwxrwxr-x  1 gdm       gdm          0 Jan 13 11:22 X1024

Can anyone post their 'working' permissions here to see if they differ?
I just tried creating a new user, and exactly the same there - will not log into a Wayland session.

I gave up and reinstalled.

New install, permissions in /tmp now look like this:

drwxrwxrwt  2 root  root          4.0K Jan 13 14:49 .Test-unix
-r--r--r--  1 wheeljack wheeljack   11 Jan 13 14:49 .X0-lock
-r--r--r--  1 gdm       gdm         11 Jan 13 14:49 .X1024-lock
-r--r--r--  1 gdm       gdm         11 Jan 13 14:49 .X1025-lock
drwxrwxrwt  2 root      root      4.0K Jan 13 14:49 .X11-unix
-r--r--r--  1 wheeljack wheeljack   11 Jan 13 14:49 .X1-lock
drwxrwxrwt  2 root      root      4.0K Jan 13 14:49 .XIM-unix

And in .X11-unix folder they now look like this:

drwxrwxrwt  2 root      root      4.0K Jan 13 14:49 .
drwxrwxrwt 20 root      root      4.0K Jan 13 15:04 ..
srwxrwxr-x  1 wheeljack wheeljack    0 Jan 13 14:49 X0
srwxrwxr-x  1 wheeljack wheeljack    0 Jan 13 14:49 X1
srwxrwxr-x  1 gdm       gdm          0 Jan 13 14:49 X1024
srwxrwxr-x  1 gdm       gdm          0 Jan 13 14:49 X1025

So looks like something went awry with wayland at some point. Now going to put everything back on and check after each thing i do that Wayland hasn't broken again.

Not going to mark myself as the solution giver, as re-installing isn't really a solution lol, so thanks for your help @zenzen and i will credit you with the solution.

I can't really tell if this is correct or not but everything seems to be working fine for me:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.