Weather App unit bug

I am using Weather app with Celsius unit, but on the notification area it shows as Fahrenheit.
Screenshot from 2024-01-05 00-11-11

Have you right clicked the system tray weather notification and checked it's settings. While it may be offered with the Weather app, it is basically it's own applet, which may not use the main applications settings.

1 Like

Try to change the unit to Fahrenheit and back to Celsius, or click on the refresh button from the Weather app. I tried to change this and it took a minute or so to update on the notification tray, so maybe it needs something to trigger the update there.

1 Like

Right click doesn't work on the system tray weather app, and yes I did change the units and check it, also I restart the system, but no works.

No issues here:

1 Like

Any chance that it's just really, really hot outside? :joy:

4 Likes

Yes, it's so hot here always :smiley:
Mine has problem, IDK why...

It seems that the unit conversion issue goes both ways, as I've just tried to switch to Fahrenheit but the weather widget showed temperature in Celsius. Even after switching locations and so on.

However, I found a temporary work around for this through dconf-editor. After installing it, launch it and search for "weather". The setting we're interested in is org.gnome.GWeather4, where you can use a custom value of "centigrade" (or whatever other unit you want).

Not ideal, but I guess most people won't be changing this setting too often anyway so it's a decent workaround.

2 Likes

Thanks, It works just like a charm

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.