Web App Manager

is there such a thing as an application similar to the one in linux mint? in which you can create web applications out of any website through a browser of your choice? I tried installing the very mint's app however it comes into some issues with the layout, the options to close, maximize and minimize the window do not show up (probably because of the way mint's desktop is set-up by default, with those options being on top of the application instead of fitting into them, but that's just my guess)

1 Like

@EdwardRodriguez Hi, this may help you :crossed_fingers:

How to download Linux Mint's Web App Manager on ZorinOs:

  1. Install needed files:
    Head to Index of /pool/main/w/webapp-manager/ and install the latest .deb file. ←(Installs the .deb file)

  2. Open Your Terminal:
    Ctrl + Alt + T

  3. Enter the commands:
    $ sudo dpkg -i #the .deb ←(Installs the program, drag the .deb package from your file manager to the terminal)
    If the installation breaks, you can fix it with:
    $ sudo apt-get --fix-broken install ←(Fixes broken installations)

  4. Enjoy :+1:

IF YOU'RE ON GNOME IT WILL LOOK VERY UGLY AND HAVE OTHER ISSUES, LMAO!!! :rofl:

This is because Mint has a full window manager and Gnome does not.
The application will work fine on Zorin OS Lite, which has XFWM (XFCE window manager).
In other words, you guessed correctly (Gnomes CSD).

I clearly didn't read OP thread properly, lmao. I think it should still work right, but it will just look out of place and not feel like a gnome app?

I would think that the header stack would fill in, but it would look odd.
But you did provide a means for others to install it if they wish. :wink:

1 Like

I hope they don't on Gnome. @Aravisian but is there a different app that can solve OP's problem?

I am not aware of one. I did take a look around the web but did not find any.

This is part of why I have changed how I make themes - to account for whether a titlebar or a headerbar / stack is used.

I heard of "nativefier" but as far as I know it uses electron and when I tried installing in a VM it didn't work because somethings were oudated (which is weird because I'm pretty sure npm is supposed to fetch the correct necessary packages by itself right?)

This article outlines how to do it if using gnome-web or Chrome:

maketecheasier... Whenever I see that, my brain reads "makeitcheesier"...

This article recommends Ice; I have not tested this in any way:

1 Like