Weird Brother printer problem

Before it prints, it spits out a blank page or a small part of what it was supposed to print.

Tried deleting/reinstalling printer. Changed a bunch of settings. There was a warning flag on the icon but it went away. Still doesn't work right.

Unplugged the printer for a while.

This is printing from Chrome. I think it works OK in Firefox. It always worked when running from thumb drive.

There are only a couple of print settings in chrome://flags/. Tried them.

Tell us which Brother printer model and whether you are printing via USB or wifi etc.

1 Like

MFC-J480DW, wifi.

I'm guessing it's Chrome. Tho I think I turned off everything I set and it didn't fix it. Even booted from the thumb drive and it worked. Ran the printer troubleshooter. Nothing.

Edit: Just reset printer wifi. Haven't tested.

1 Like

Another user @Frog with a Brother printer having issues. Something to think about - printer - #38 by Frog

Frog's wifi printing issue was related to NordVPN.

@TabNumlock Question. Are you using a VPN?

1 Like

No VPN. My icons are also disappearing from my desktop, have to reboot.

When printing the LA Times crossword, I noticed this extra printer that does not show up in Printer/Settings.

Is there a command to delete all printers and start over?

Edit: I ran diagnostics again and the other printer showed up. Can't delete.

Screenshot from 2022-02-27 17-41-56

1 Like

Mine will sometimes give me blank extra pages ..... it gave me one when I started printing this morning (with my VPN shut off) printed about 20 pages with no trouble except the fist blank page .....

With mine I have found that if I pack the paper to tightly or put in to much paper it will give me a blank page after each printed page .... also if I use ultra cheap paper it will do the same thing ....

I don't think the suggestions I gave about are your problem but just something to be aware of for future reference ....

As to the double printers in the photo above in your connect setting when you open Printers - Localhost/Server/ Connect you will see a drop down menu with Connect to CUPS Server and LocalHost it maybe at some point you clicked on LocalHost and it gave you two printers in your display ..... when that happened to me I just clicked on the local one .... you right hand choice in the picture above (the selection check mark will move to that printer) then you can right click and say delete .... should remove it ..... it did with me ....

Says cups server. When I delete it, it comes right back.

Should I try?

systemctl stop cups-browsed
or
systemctl disable cups-browsed

1 Like

Sorry not sure as it deleted the extra one for me ..... sorry

Unplugged printer, rebooted PC, then searched for printers. Got this.

Screenshot from 2022-02-27 19-17-21

It's working on the LA Times crossword, so far. I have wasted a ton of paper.

I read somewhere that it's normal to have two icons. Hope so. At least this one isn't a duplicate.

This is a printer/scanner, BTW.

Edit: Just noticed is says "Generic txt only printer".

1 Like

OK, the puzzle printed out normally this morning and twice as fast. Maybe it's fixed.

I guess it's nice a having text only printer. People use them for something. Not sure what.

My disappearing desktop icons (and other stuff) sounds like a memory problem. Gonna take them out, clean and swap them (old Lenovo biz PC).

1 Like

Still printing normally. Although the printer once disappeared and I had to re-add. Not surprising since my desktop icons and other things have been disappearing. Suspect memory.

I took all four memory sticks out and swapped the banks and sticks within the banks. Cleaned the contacts by sanding with white paper. Checked for golden retriever hair, blew out the computer with my electric leaf blower.

So, are you having printer problems? Do this first:

*Unplug printer
*Reboot PC
*Plug printer in
*Find printer

BTW, Printers are not normally on your Start Menu in System Settings. But you can add them using the Main Menu app. Once there, you can add to Favorites or Desktop. Makes it easier when screwing around with your printers. It should be in the tray.

Update: No disappearing icons or printers all day. Might be fixed. Fingers crossed. Preparing to install Zorin on all my PCs (4 old Dell and Lenovo biz PCs).

Day 2: Still no memory cliches. Guess I fixed it. Puzzle printed fast.

So let that be a lesson. Many probs are caused by memory. With my 4 sticks, we're talking about 300+ connections. Also, if the memory is bad, you can test by removing half.

2 Likes