Weird ethernet connection issue.....WTF?!?

Morning, guys.

Longtime Zorin user here. Been playing around with it ever since Zorin OS 8 (9?), many years ago. Haven't visited the Forum for quite some time, certainly not since the Forum 're-vamp' - which I like, BTW!

Switched to Linux back in Summer '14, after XP went EOL. Went through the usual 'distro-hopping' phase, like all noobs do. At the time was running an elderly Compaq Presario desktop tower PC, with just 3 GB DDR1 RAM. Came to the eventual conclusion that all mainstream distros/re-spins/re-masters, etc, were really too heavy for the old girl, so have been a regular 'Puppy' user for the last 6-6 1/2 years.

(I moderate over at the new Puppy Forum, and also at BleepingComputer. I don't consider myself any sort of an 'expert', by any means; more like the 'eternal noob', since most of the time there's usually summat new to get yr head around.....but I like helping folk out where I can.)

Out of all the mainstream distros, however, the only one I ever really liked was Zorin; I just love Kyril & Artyom's approach to stuff! To that end, I've always maintained an up-to-date full install on a USB 3.0 flash drive (SanDisk Ultra 'Fit' 128 GB.) Currently posting from Zorin 'Core' 16.....

Now then; question time.

What's with the ethernet connection stuff these days? I understand Zorin 16 is based on 'Focal Fossa', yes? We had ethernet 'issues' with the Puppy spin on 'Bionic Beaver' (Bionicpup64), 'cos it was the first one where the new interface naming convention was introduced, but the current Puppy 'flagship', Fossapup64, has been as smooth as silk ever since it was first produced; no connection problems at all.

Fortunately, my current rig - an HP Pavilion midi-tower - is one of these new-fangled contraptions that has wireless as well as ethernet.....and that's what I'm connected on right now. For some reason, the Realtek r8169 module is recognised by the kernel; it comes up as 'Ethernet connected', but.....there's NO actual connection, y'know?

UFW is active and set-up correctly.....but if I try switching over to ethernet, Slimjet insists it "can't connect".

Huh??

Any ideas, amigos?

Mike. :thinking:

You might try Realtek r8169-dkms.

sudo apt install r8168-dkms

You know how realtek loves to withhold from open source...
You are not alone and the Realtek problems have been one of the most triaged on the board.

Hi, Aravisian.

Hmm. I see. Nothing new there then, is there? (Jeez...)

See, normally I'd never have bothered with wireless.....at all. Like many of us, I keep a couple of wireless dongles handy (both the good old 'standby' RTL8192CU, 'cos it's been in the kernel since forever, really, and never gives any issues.)

This new HP of mine is the first I've ever had which happens to have a Bluetooth/wireless combo chip in it, so wireless is 'on hand' all the time. I'm still having trouble getting my head round the concept of a desktop with built-in wireless.....I keep looking for a lid to close at the end of a session! :smile:

I'll keep a weather eye on developments; see what comes up, like. Thanks for the heads-up, anyroad.

Cheers!

(Where's Wolfman, BTW? Is he still about? He gave me a whole heap of good advice when I first started with Zorin, way back when...)

Mike. :wink:

Haven't seen Wolfman active in a long time. Not sure if he moved on to other things or quit the internet and moved to the mountains.
ZorinAntwerp switched to Deepin and became DeepinAntwerp. You can still find him on the Deepin Forums. Swarfendor switched to Devuan but as coincidence would have it, posted on here just a few hours before you did.

At least you have net access. Many don't and several have been really struggling since, without net, it's hard to run sudo apt install...
We could run through the usual troubleshooting terminal commands and rigamarole of you want... But I suspect you have done all that and could teach me a thing or two.

Hah. Nope, I very much doubt that.

Networking is one of my pet hates. TBH, out of all the many aspects of Linux, it's my "bete noire"; as far as I'm concerned, it's deepest black magic..!

I've tried, many times, to get my head round the whole concept of networking, but invariably it starts to spin..... (ouch..!)

I'd forgotten about Swarfendor! He was the other one that was very patient with a noob, many years ago.....for which I was very grateful at the time. Nice to know he's still around. Decent bloke.

Cheers.

Mike. :grinning:

1 Like

I still have bookmarks (and pdf crib sheets) to Wolfman's Partitioning and Installation advice from the old Forum. They were so useful and clear to understand when I first tried Linux (i.e. ZorinOS 12).

1 Like

Hi, zabadabadoo.

Coincidentally, I've still got those tucked away myself! As you say, they were really clear & easy to follow, and, despite the fact that Puppy does things rather differently to mainstream distros.....we very rarely use the terminal, for one thing, much preferring to dive-in to the file system and physically move stuff around/create links, etc.....I found Wolfie's advice useful for a good while after leaving mainstream Linux.

That's one guy I shall miss.

Mike. :wink:

1 Like

I too appreciate several of the greats who have posted on the Zorin forum. A couple of the people you have mentioned, haven't posted on the forum in what feels like a decade, like Wolfman for example.

SWARF left about a year ago, but returned for a moment because I summoned him. I am also hoping that he checks out OS 16, I really think he should test it and see if he likes it.

I have been on the forum for years, but if you have been gone for all that time, then you would not recognize me. I took a several month sabbatical though, and now I am back.

1 Like