Weird Issue with WIFI

Hi everyone, I installed Zorin os 17 Core on two DELLs Latitude E6230 recently. I am having issues with WIFI. Every time I restart the computer, WIFI is not coming up at all. On the other hand, if I shutdown the computer & reboot, WIFI is working fine. Would it be possible that a 'restart' disables WIFI and the boot process (when you restart only) is not recognized at all ?

I am not having this issue on other computers running 17 ... like Lenovo's laptops and other DELLs.

Thanks in advance.

First thing: On Zorin OS be sure to launch terminal and run

sudo apt update && sudo apt upgrade

This likely is a BIOS setting that needs to be adjusted.
The easy way to address this is to restore all BIOS settings to default. The more nuanced way is to examine all settings and identify the culprit.
Usually it would be a PCI enumeration value since Wifi cards often occupy a PCI slot.
One thing to double check though, both if you restore to defaults or if you Identify and change a setting is whether Secure Boot is enabled or disabled. Secure Boot is generally for Windows OS use and can interfere with GnuLinux applications and drivers.

If that is no good; then you would want to check your kernel version:

uname -r

and may need to test a different kernel. You can try an earlier one from Grub Menu > Advanced Options for Zorin.
For a later kernel, you can install a TuxInvader patched Mainline. Which depends on whether you are using Zorin OS 16 or Zorin OS 17. Also, please state if youare dual booting Windows OS.

Perhaps this askubuntu thread may assist you:

Thanks for your help Aravisan. Here's the requested info. To answer your question, one DELL is dual-boot the other one not.

daniel@Zorin4:~$ cat /etc/os-release

PRETTY_NAME="Zorin OS 17"
NAME="Zorin OS"
VERSION_ID="17"
VERSION="17"
VERSION_CODENAME=jammy
ID=zorin
ID_LIKE="ubuntu debian"
HOME_URL="Zorin OS - Make your computer better."
SUPPORT_URL="https://help.zorin.com/"
BUG_REPORT_URL="Send Feedback - Zorin OS"
PRIVACY_POLICY_URL="Privacy Policy - Zorin"
UBUNTU_CODENAME=jammy
daniel@Zorin4:~$

daniel@Zorin4:~$ uname -r

6.5.0-18-generic

daniel@Zorin4:~$ sudo apt update && sudo apt upgrade

Hit:1 Index of /ubuntu jammy InRelease
Hit:2 Index of /ubuntu jammy-updates InRelease
Hit:3 Index of /ubuntu jammy-backports InRelease
Hit:4 Index of /ubuntu jammy-security InRelease
Hit:5 Index of /ubuntu jammy InRelease
Hit:6 Index of /zorinos/apps/ubuntu jammy InRelease
Hit:7 Index of /zorinos/drivers/ubuntu jammy InRelease
Hit:8 Index of /stable/ jammy InRelease
Hit:9 Index of /zorinos/patches/ubuntu jammy InRelease
Hit:10 Index of /patches/ jammy InRelease
Hit:11 Index of /zorinos/stable/ubuntu jammy InRelease
Hit:12 Index of /apps/ jammy InRelease
Hit:13 Index of /drivers/ jammy InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ sudo lshw -C network
[sudo] password for daniel:
*-network
description: Wireless interface
product: BCM43228 802.11a/b/g/n
vendor: Broadcom Inc. and subsidiaries
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 00
serial: 34:23:87:45:57:a3
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=192.168.0.105 latency=0 multicast=yes wireless=IEEE 802.11
resources: irq:17 memory:f7d00000-f7d03fff

swarfendor437

I already went thru this process and the latest driver recommended was installed properly.

Thanks to you both.

Have you yet run:

sudo apt install firmware-b43-installer b43-fwcutter bcmwl-kernel-source

1 Like

Yes I did ...

Here are 2 printscreens I just generated.
The first one is when I clicked the RESTART button, the second one is when I power OFF the computer and turned it back on. You see the WIFI icon on the 2nd printscreen not on the 1st one ...
Screenshot from 2024-02-16 15-25-34

Screenshot from 2024-02-16 15-27-11

Is this computer that is having the difficulty dual booting with Windows OS?

Not at all... All good here !

Joining additional info here ... When I do a 'RESTART' on top of not having the WIFI icon, I get this message if I try to connect to a network ...

Screenshot from 2024-02-16 15-45-32

I am sorry, I think I worded my question very poorly.

I mean, is the affected machine also dual booting Windows OS?

BTW ... You guys are doing a great job :slight_smile: Thanks

Both machines are having this issue. One has dual-boot WIN10 & Zorin, the other one Zorin only. Both computers work fine (WIFI is available) as long as I power them OFF and ON again. The 'RESTART' button if pressed seems to disable WIFI ???

Then we can discount the thought the Windows OS is retaining control of the hardware.

Have you checked the BIOS Settings on both machines?

Have you yet tested a different kernel?

Hi, take a look here:

and here:

https://www.makeuseof.com/fix-ubuntu-wifi-not-working/

I installed Zorin os 16.3 and had the same issue with WIFI, then upgraded to Zorin 17 right after ... same problem.

Thanks swarfendor437, I'll have a look at it ...

Hi ... Suggested links did not help. All the proper drivers and configurations files are fine and up-to-date. Still, for whatever reason ... if I issue a shutdown -r from a terminal session (equivalent of RESTART button) the WIFI is not coming up. If I issue a shutdown -P (equivalent of POWER OFF button) and bring the computer back ... the WIFI is working like a charm ...

Hi everyone,
this is to let you know I found why I had those weird issues with my WI-FI. For now i'm only connecting to 2.4GHz networks. Not saying 5GHz networks don't work but if I am connected to 5GHz network and if I do a 'sudo reboot' or click the 'restart' button, WI-FI will not be coming up. WI-FI reconnects properly if I do a 'sudo shutdown' or click the 'Power OFF' button (no matter if I am connected to a 2.4 or 5GHz network).

Before finding this ... I used the last 3 available versions of the DELL BIOS and it did not fix anything. Also made sure I had the proper drivers. Tried to boot to different kernels (no luck) ... I have an IPTV app running and 4 computers (Windows 10 and/or/both Zorin) running properly with a 5GHZ default connection. For some reason, these DELL Latitude E6230 have WI-FI issues connecting/re-connecting to a 5GHz network (only when rebooting them).

i'll be digging a bit more on this, but so far it's working ...

Thanks,

2 Likes

Finally ... Issue solved.
It was a configuration issue in the router itself. Found it when I ran the following command:

iwlist wlp2s0 freq

wlp2s0 32 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 32 : 5.16 GHz
Channel 34 : 5.17 GHz
Channel 36 : 5.18 GHz
Channel 38 : 5.19 GHz
Channel 40 : 5.2 GHz
Channel 42 : 5.21 GHz
Channel 44 : 5.22 GHz
Channel 46 : 5.23 GHz
Channel 48 : 5.24 GHz
Channel 50 : 5.25 GHz
Channel 52 : 5.26 GHz
Channel 54 : 5.27 GHz
Channel 56 : 5.28 GHz
Channel 58 : 5.29 GHz
Channel 60 : 5.3 GHz
Channel 62 : 5.31 GHz
Channel 64 : 5.32 GHz
Channel 66 : 5.33 GHz
Channel 68 : 5.34 GHz
Channel 96 : 5.48 GHz
Channel 98 : 5.49 GHz
*** Those are the only channels available for my specific device as per the iwlist command:

freq[uency]/channel
Give the list of available frequencies in the device and the number of
defined channels. Please note that usually the driver returns the
total number of channels and only the frequencies available in the
present locale...

My router was configured to channel 149. I changed the channel to one of the listed 5GHz channel as per iwlist and it resolved my issue.

2 Likes

That is some impressive troubleshooting. I'll bookmark this thread to know what to look for in case I run into strange behaviors in the future. Thanks for the update!

1 Like

Thank you !