Weird pixelation at right click menu's & other places

I have been using zorin for about 3 days.
As soon as I logged into zorin and used brave browser I encountred some wierd pixelation while right clicking a site...
I tried again on chrome but the same thing happened...
I tried to bear with it and watched some video content and baam. Same thing happend. It doesn't affects the video's much as the pixelation only happens in certain places but right click menu is totally unreadable. On top of that i sometimes see some letters or numbers in the pixelation....
Please Help.
Hardware Info: HP-14s-DK0501AU
Processor - Ryzen 3500U
Graphics - AMD Radeon vega 8 graphics

1 Like

Does this happen with another non-Chromium browser, namely Firefox? I've also see similar glitches with Brave in particular, although not as bad as that, mostly just random pixel degradation around letters. And not just in ZorinOS but on other distributions as well, so I suspect it's the browser itself.

i strongly suspect the AMD graphics drivers.

You may need to try installing the drivers directly from AMD.

1 Like

I'm getting the same on SRWare Iron (basically Google Chrome with all the corporate spyware neutered), latest version. I thought it was video driver-related, but unless you have the exact same hardware as I've got, that's not likely.

Mine usually happens if the cursor is over a picture on a website, and I've scrolled to the limits of the page, then try to scroll more after the page has stopped moving.

HP 17-cp1035cl laptop
AMD Ryzen 5 5625 U CPU
Integrated AMD Radeon graphics

To be honest it works pretty well for me, most of the time I don't even notice it, so I've never looked further into it. But it's definitely only on Brave, not even on Gnome's Epiphany I see the glitch.

From the O.P. it looks like the Popover menu's are what's glitching - which points toward overlay which points toward graphics drivers IMO.
If I am wrong or misunderstanding the O.P's post - please let me know.

Huh. Maybe your'e right. I just tried it on firefox and voila it works....
But in this day and age all the "good" browsers if you will are chromium based and I am not too eager about switching to firefox.
Is there any solution to this??

Yeah i thought so too... but weirdly it works perfectly on firefox.

Like I said above I've only experienced small glitches myself, nothing that would bother me enough to go and look for a solution.

But I suppose it's possible that there are a few factors at play that combined are causing trouble somehow. You can try to disable graphics acceleration and test if that makes a difference.

You should choose your tools on the basis that they provide the functionality that you need. If Brave doesn't work, don't use it.
Personally I keep a few browsers always installed, and I've developed my own workflow using dedicated profiles in each of them for different uses.

I'm betting there's a flag we can change under chrome://flags that'll fix it.

Huh....i changed the vulkan graphics settings under flags and the menus are ok.
But now youtube seems wierd.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.