Weird X Symbol Instead of Mouse Cursor. Lots of Other Problems

Hi. I’m using ZorinOS Education Lite edition.
It’s been great until suddenly, the mouse cursor is replaced by this x-symbol.
(I also noticed file explorer windows are now missing their top part).
(See screenshot at bottom).

And now there’s various other problems:

  • I can’t maximize windows.
  • Sometimes I can’t move or resizeshortcuts windows at all.
  • And if I can, it’s very slowly.
  • My shorcuts for tiling or hiding windows don’t work.
  • File Manager/File explorer windows are always on top
  • I can’t alt+tab.
  • Firefox browser window now has a weird grey border that covers file explorer.
  • I can’t even name a screenshot file.
  • I can’t even click on the ‘post/submit’ button in ZorinOS.

How do I fix this??? Please help. I like ZorinOS, but it’s kind of not-usable right now…


P.s. The x-cursor is in that phone-photo.
I had to take a photo of the x-cursor with my phone, and then take a screenshot of that pic on my computer because the photo was too big.

Please hit alt+f2 and type in it

xfwm4 --replace

This should bring things back to functional again. If so, close all open processes. Then open your file manager, firefox, take a screenshot and save it- just use some apps. Then, log out and in. If upon login, everything remains normal, that means that your configuration files saved your window manager session.

If things are not normal after login, please open your home folder, hit ctl+h to reveal hidden files if they are not revealed already and right click
rename it to
Then reboot.
This will reset your congigurations to default. If all is then normal, you can sift through ~/.config-bkp and copy over any configuration files you need that are Not Related to XFCE Window Manager.

1 Like

Thanks so much! It fixed it, even after logout as well as restart.
Also, super quick response! Thanks!

I noticed when typing the xfwm4 --replace, it was typing extra letters, but I managed to type it in properly, and typing works fine now.

Also, I do remember checking “save sessions for future logins” when shutting off, which probably helped “cause” the problem. I’m gonna leave that unchecked from now on.

You should keep “save session for future logins” checked. In fact, that was part of your solution, saving you from needing to replace your ~/.config directory as it saved the XFWM4 settings for the next login.

I am not sure what caused your XF Window Manger to crash. There are a few things that can crash it. You may retrace your steps to what was going on before everything went nuts on your screen.

Ok, I don’t quite understand, but I’ll checkmark it again.

I honestly don’t know. I wasn’t doing anything unusual. My guess is I accidentally hit some keyboard shortcut without even noticing it. But I have no idea what shortcut it would be (I tried F1 to F12, by itself, with windows, with alt. Nothing).


P.S. the problem came up again this morning…
I fixed it again.
This time, I renamed the .config folder, deleted it, and changed my preferred shortcuts again.

p.p.s. For any other noobs out there who can’t find .config folder:
my .config folder didn’t have a ~/ in front.
And it was in home/myusername. Not exactly in the folder called “home”.
And also, I didn’t realize it was a folder at first.

I also ran an update that showed up this morning.

Hopefully the problem stays fixed this time.

1 Like