What does this error in Software/Updates mean? Only results I find on google are for Fedora

error calling startservicebyname for org.freedesktop.fwupd timeout was reached

I did sudo apt update --fix-missing && sudo apt upgrade but nothing was upgradable.

Doing sudo service fwupd start just hangs in Terminal


1 Like

It seems it's a simple program to update firmware on your machine. According to this wiki Gnome Software has built-in support for it which is probably why you can't find it.


Some issues I've found mentioned this is simply this program taking too long to fetch the updates but I have no idea if this is the case. I would try the good old restart and see if this fixes the issue?

I know WHAT it is. I need to know WHY it's erroring out and how to fix it.

No clue honestly, have you tried to restart? It's amazingly effective in fixing this type of single occurrences.

1 Like

Obviously yes.

You didn't tell if this warning appeared after downloading an update or opening Updates. Anyway, before accessing Updates again, right-click the taskbar > System Monitor > Processes > right-click gnome-software > Terminate and open it again to see if works, otherwise Kill and check. Please don't attempt this procedure while installing an update or software as I never tested it in such situation and so I'm not aware of its consequences.

That's because I did neither. The window was open, on its own, when I woke up. I usually do my updates manually, through terminal. The window was open, as I screenshotted it above with no input from me.

Already terminated it through System Monitor and tried running commands in Terminal, as stated above, also.

1 Like

This most often is caused by Flatpak trying (and failing) to update. This throws that message in the Gnome Software Store as Software Store is integrated with the Updater and with Flatpak and Snap.

If Flathub has a brief outage, packet drop etc, or if there is a sudden spike in traffic, this can cause this.

My own solution to this is that I do not use Flatpak or Snap and thus, I never get this error.
However, for many users, that is not an option. So things you can do to resolve is reboot, restart the service or wait until Flathub has resolved their brief outage or traffic clog.


What about downloading the desired software directly from FlatHub or Snapcraft? While Software Center fails, the browser downloads it anyway. The problem then may be that the user needs to run the installation manually facing some issues :person_shrugging:. I feel much more easier to download through Software Center as it installs software on its predefined directory and creates shortcuts so I don't need to do anything more, most of the times.

I understand this is your go-to answer for many of the issues, here, but this error is verified to be separate from flatpak. It's a service that runs on the system, independently of any package manager. It's built into the OS and is not a secondary install.

I have verified that as the issue as trying to launch the service in Terminal shows an error to launch. It should always be running.

No, it really isn't.
I gave that answer because it is accurate.

systemctl restart fwupd

Reboot and test.

I feel like you think I was attacking and I assure you I was not. Just an observation.

Far as I am aware, flatpak and snap do not install system-level apps.

Also, your systemctl option failed like the other i tried.

Off the point of the thread but Snap kind of can. (Do not think Flatpak has this ability)

Again not helpful to the point of the thread. Just noting

This was recently discussed in regards to Gnome 42 packages being offered for Snap.

There are certain known issues that repeat. This is as true for Flatpak and Snap as it is for XFCE window manager or Gnome... When we see them, we are likely to try checking the known and common things first.

Hmmm... what about:

sudo apt install --reinstall fwupd

There may be a hiccough in the files themselves.

lol did that, too and it failed to re-enable it upon reinstall.

At least I feel like I know what I am doing. tried everything everyone has mentioned and then some.

Also, I am still on Gnome 3.38 (Zorin OS 16.2 Pro) - Only on Gnome 4* on a VM.

I agree. This should have resolved.
Ok.... try a hammer?

killall gnome-software

rm -rf ~/.cache/gnome-software

sudo apt install --reinstall gnome-software fwupd gnome-software-plugin-flatpak gnome-software-plugin-snap

Launch Gnome Software and look for errors. IF you see any, close it out, open terminal and enter in


to launch and relay any errors displayed in terminal.


What does

systemctl daemon-reload fwupd-refresh.service

yield in terminal?


Ok, one of the MANY steps I did must have worked at some point,. because on my latest reboot the error is gone and fwupd is able to run normally.

Also, as fwupd is hardware specific and Dell is REALLY REALLY good at releasing new ones (like WAY better than any other manufacturer) I wonder if the fault lies in something they did. Maybe my multiple reboots finally enabled their patch or something?

No way to know, yet, but hopefully this thread helps someone else.

Cheers for all the help.

1 Like


I thought this was a persistent error and I was trying to figure out why it wouldn't solve...