What is the correct AlsaMixer parameters?

Recently, I've installed Zorin OS 16.1 on my old Toshiba laptop. Its microphone is not working. I've changed some parameters in AlsaMixer but still I can hear nothing from a recorded voice except a ssss sound. I'm wondering whether it's a hardware issue with the microphone that I've connected to my laptop or there is something wrong with the sound settings as in AlsaMixer screenshots attached here.
all
capture
playback

@sara Hi and welcome to the forum. Can you please tell us which edition of ZorinOS you have. Also can you edit your profile to indicate that there, as that will avoid us askimg the same question again.

Is it the inbuilt microphone or plugged in microphone you can't hear?
If a plug-in mic, how is it connected (3.5mm jack or USB)?

I see from screenshots that [Speaker] channel is turned off. What happens if you increase the level of the [Speaker+] channel?

Is there an Alsamixer channel marked "Loopback" also "Auto-Mute" (not shown on your screenshots). If so try changing those settings.

Alsamixer is a good place to play with sound settings to overcome a problem, but people's setups differ. It is sometime a case of trial and error before success.

There have been some reports on the forum of OS updates affecting audio functionality of late. If your mic worked before an update and isn't now then you could try booting a previous kernel.

EDIT: You could also double check the basic sound troubleshooting guide here:

1 Like

Hi! Thanks a lot for your reply and the suggestions.
I'm using Zorin OS Lite. The microphone is a plug-in 3.5mm jack.
I've tried all your suggestions with Alsamixer (changing "Loopback",.., increasing "Speaker+" level,..), and tried the solutions on the "Set Up Sound" guide, unfortunately none of them improves the microphone issue.
You are right, Alsamixer is a try and error case.
I had not used this old laptop for long time. After having tried all the solutions you mentioned, I think I'd better check the laptop with a technician, most probably it is a hardware issue.

I installed pipewire and all my problems dissapeard.