What is the path of applications (Snap) for adding to startup?

Dear Team,

Can someone help me to find the path of applications to add to "Startup Applications".

The targeted applications are installed using snapcraft.

I tried this, /var/lib/snapd/snaps/mailspring_506.snap

not working!

Thanks
Akhil

Might this hep?

Thank you for the response.

I usually Google it and search in askubuntu before asking here. I tried that and it didn't work for me.

The fun part is, a couple of days back (Before I deleting zorin. Now running on external SSD) I used a path similar to the one I posted and it worked. But I forgot the path! :pensive:

:crying_cat_face:

I wonder if it is something to do with the recent kernel update.
@Aravisian @zabadabadoo might have a better idea than me.

Another problem is that I have absolutely no Snap apps on my system thanks to the excellent tutorial by @Storm

2 Likes

What I meant is, "I forgot the path" and I'm sure that the issue is not because of zorin updates.

1 Like

I was able to recollect the path!

This is the path I added to Startup Applications:

/var/lib/snapd/desktop/applications/mailspring_mailspring.desktop

And it worked!

I hope this will help someone :slight_smile:

Thanks!

1 Like

@akhil I find it a good idea to keep a notebook of changes and command entries to look back on. Bit like recording a lab experiment, you can sometimes work out where things went wrong when the result is Frankenstein does not play nice.
Alternatively you can bookmark your post on here so you can find it if needed in the future.

3 Likes

Yeah, I already bookmarked all the needed tutorials in case I need to re-install Zorin again.

I do both.
I have one dedicated USB key named "Linux" where I store the text files for the procedure, tips, commands etc. These text files also include links to the websites if applicable.

This way, even if websites got disappeared, I still have a necessary information :slight_smile:

1 Like

I recommend Notion :slight_smile:

This?

But text files are forever :wink:
I can even read them in DOS.

1 Like

Yeah! But, if you start using Notion, you'll never use anything else :stuck_out_tongue:

While I fully understand your point, it is still hard to beat the universality of .txt
There is no need to install anything nor internet connection.

This is the content of my Linux USB.

2 Likes