When i enable bluetooth, it does not show any devices

it just showing that when i enable bluetooth. please help me to fix these problem. it is not showing any device.

Can you please post the output of

sudo lshw -c network

description: Ethernet interface
product: RTL810xE PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
logical name: enp1s0
version: 05
serial: 00:e0:4c:6c:0d:a1
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.13.0-51-generic firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=twisted pair
resources: irq:16 ioport:e800(size=256) memory:fdfff000-fdffffff memory:fdff8000-fdffbfff

Hmm... this should have bluetooth support (Radio driver) in the wifi driver.

Have you tried installing blueman

sudo apt install blueman

And launching blueman to adjust the bluetooth and try connecting to devices?

Thanks for reply. after installing blueman when i disable bluetooth this icon is showing but when i turn on/enable bluetooth it disappears and still showing "bluetooth truned off". what should i do next?

Let's try:

sudo rmmod btusb

sudo modprobe btusb

sudo systemctl enable Bluetooth

Just as you see it here with the asterisk too:

sudo apt install -y bluez*


sudo apt install --reinstall bluez*

sudo systemctl enable bluetooth

sudo systemctl start bluetooth

when i run command
Screenshot from 2022-06-28 21-16-03
first time it is showing this and second time this
Screenshot from 2022-06-28 21-09-24
what should i do next.

Please see above where i posted during your Repost.

nothing happend after this command
Screenshot from 2022-06-28 21-27-12

Have you tested a Bluetooth device?

it is not searching for any devices.

I am stumped.

The only thing I can wonder about now is... is it the Bluetooth device itself...

bluetooth device means problem in my bluetooth driver?

No, in the hardware.

in my bluetooth adapter?

Yes, that is possible. I am not sure of anything else driver related.
Zorin OS should come with all the Modules you would need.
You can try this anyway, though I doubt it will work:

sudo apt install linux-generic

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.