When I minimize a window, its contents remain on the desktop

When i minimize a window there's a small chance that my wallpapers will be changed to contents of window. Here's how it looks like:


Any variants to slove it?

I slowed it by doing this:
sudo apt update && sudo apt install --reinstall zorin-os-desktop
Thanks to Aravisan in Minimized windows stay visible - #3 by cactustit

Well, it happened again...

... and the previous fix didn't work? Have you received any updates to your system recently? If so, can you recall which part of the system got updated?

1 Like

I had probs like this, disappearing icons and stuff staying on the screen. Removed, cleaned and swapped my memory sticks. Seems to be fixed.

1 Like
  1. Nice choice of games you got there :wink:
  2. what happens if you hit Alt+F2 and type "restart"? (or just "r")
  3. are you using Nvidia drivers by any chance?
1 Like

This looks like the same issue I was having. If you read my post you can see I found it only started occurring after using gestures to switch desktops, but only sometimes it starts to happen. See if it happens after doing that, then trying to minimize.

I confirmed this bug occurring in any hardware and on a fresh installation so its definitely a bug of some kind, maybe with the x11 gestures extension (doesn't occur is that extension is disabled)

1 Like

considering the gestures were initially supposed to only work on the Wayland session, and this X11 session having them enabled through kind of a "hack" with this extension, it might well be that the implementation on X11 is just flawed as, well, it wasn't designed to be used on X11 :confused:

1 Like

I was just about to create a new thread about this issue. I'm having the same issue with my system right now. And I couldn't find any solution on the internet so far.

1 Like

What method do you use to minimize the window?

1 Like
  1. thx
  2. i didn't tested right now
  3. no, im using amd

The minimize button on top-right of window

Have you tried:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt upgrade

1 Like

No, i didn't tried. But i will try now.

Can I try this one too? But I'm using an NVIDIA GPU.

1 Like

Oibaf is for AMD GPU only.

1 Like

The Nvidia one is

sudo add-apt-repository ppa:ubuntu-x-swat/updates

1 Like

To be honest, it's not a big problem for me. I can remove it by "r" comand in alt+f2. (Thx, TGRush) for once. Thanks for your help! Topic is closed.

a fix for this would still be appreciated, so I will try getting precise information on recreating this issue later, and then report it in full detail

2 Likes