When i try to install any app from software store he say that: Unable to install apps from the zorin store

can you help me

Try running a DEB package using Gdebi

sudo apt install gdebi
1 Like

You can try to install the same package from the command line directly:

flatpak install com.visualstudio.code

It will ask to also install the "required runtime" which the first time may take a few minutes.

Note that using flatpak as the package format comes with a few restrictions in terms of permissions. For example the integrated terminal within VSCode may not work correctly when reading files from your file system.
As a workaround to that you can install another package called Flatseal, although unfortunately I haven't used it and I'm not too sure how it works so I'll let others expand on that.

The other option and in my opinion much better one, is to install the .deb package. This is the native format for packages on distributions based on Debian or derivatives, and should work right out of the box. Since Visual Studio Code is not in the official repositories however, you will need to download it from their official website:

And last but definitely not least, I would even suggest to download VSCodium instead. Besides the obvious benefit in privacy, you can add their repository so that it gets updated automatically with the rest of your packages. It also comes as a flatpak if you care to install it as such.

1 Like

I put this code in the terminal, but the problem exists.

sudo apt install gdebi

I put this command, but it says that there is an error.

flatpak install com.visualstudio.code

I downloaded the program from the official page, and when I open it, it takes me to the system store and tells me to download the program from here. When I click on Install, it tells me this message that I saw

Try downloading the DEB, then running

sudo dpkg -i [DEB Name]

Replace [DEB Name] with the exact name of you downloaded DEB file (Use Tab to autocomplete)

For flatpak option: run flatpak update first, and then try to install again.

For the deb option, did it offer you the option to install from the software store? If so, it will actually redirect to the flatpak option which is the only one it can find over there. Try to click on "Run anyway" to make use of the .deb package you downloaded.


By the way, normally I wouldn't recommend installing software like this and stick to the official repositories or flatpak (which is another reason to use VSCodium if you ask me).
To double check that everything is fine you should always compare the checksums of the file you download with the ones provided on the product's website. If you scroll down a bit on VSCode's website you will see a link to the checksums. You can then run the following command:

sha256sum <name_of_file>

Make sure that the output matches exactly the string for the version you downloaded.

Also I'm pretty sure nobody realised, this should be in #general-help, not #installing-zorin-os.


Fixed it.

The answer is at the bottom of that screenshot - the system did not like the untrusted signature of the package you were trying to install!

How can you fix this untrusted signature? I can install it just fine :confused:

The short of it is- this is a common Flatpak error.
A person might have some luck running:

sudo flatpak repair

flatpak update

But many users report that also does not work - This is because the only way the above can work is if they are running something in Flatpak that has since been patched / repaired.

The quick and easy fix: Do not use Flatpak.
Instead, install VSCode with the following:

wget -q https://packages.microsoft.com/keys/microsoft.asc -O- | sudo apt-key add -
sudo add-apt-repository "deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main"

sudo apt install -y code


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.