When things go wrong caused by WINE

or rather, when certain Windows software sends things ... "out of range"!
Recently, my youngest wanted to play an old favourite game of theirs, Petz5:

(Just to add this was on a different Linux distribution!) Petz5 didn't cause the issue - see end of thread! Petz5 was working hunky dory after I had copied everything off the CD into Wines C:/Program files (x386), gave all .exe files permissions to run as executables and installed the game without a glitch.
I could not access GRUB as the distro had set the timeout to zero, options hidden, and boot time 0. I tried to restore using Timeshift but it made no difference.
So the first thing I had to do was edit GRUB. Having logged into the Desktop Session facing "out of range" the only way forward was to use Ctrl+ Alt+ F1 through F6 should give you access to TTY termnal login. Login with user credentials, followed by normal login password. Next:

sudo nano /etc/default/grub

This opens the GRUB configuration - I had to change the timeout from 0 to 10, and change options from "hidden" to "shown". There was another setting that I also changed to 10 - can't remember the line. To write out the amended file you then press Ctrl+ O, then Ctrl+ X to exit. For the GRUB to be changed you have to reboot the machine.
I booted into recovery mode and tried to do 'fsck' but sdb2 (/) was locked so I could not run it. I dropped to root terminal and tried to

umount /dev/sdb2
  • but still some issue. I then typed

this got me to the desktop but I had forgotten I was still as root and so the desktop I saw was root and not user! LOL!
I then opened a Konsole (Terminal as it is Plasma KDE) and entered:

sudo timeshift --restore

I then chose the correct image I wanted (20.03.2022) and got it restored. User desktop back in place! Phew! But not everything is yet over! Resolution stuck at 1024x768!
Solution? Something I don't like to do but had to use Driver Manager to install most up-to-date nvidia Driver, 510. Rebooted and now I can change display to correct size!
And the offending piece of Software? U.B. Funkey! Remember these?
The software was 2007 - I tried installing Windows XP in Virtual Box, but because most VM Software looks to native hardware, Windows XP did not have the USB drivers for this rig! [Asus MAXIMUS VIII Ranger] LOL! Which led to the installation of Wine 7.0 stable then the disaster! The game began to work (music that plays when starts was correct, display turned black in what I thought was about to launch the game but instead created "out of range" - Be careful what you do with Wine! Or rather be careful which apps you use with Wine! LOL!