Whenever opening up application, the screen goes back to lock screen

So basically whenevre i open up any game such as Genshin , a black screen posp up and a few sec later the lock screen comes up and i am unable to open that application. Not all games perfrom the same way, most work but for genshin it goes back to lockscreen and it closes every process which was being used before, any solution? I am using Zorin os core as main and not dual boot a

Hi, and welcome!

Does this happen with games only, or are there any other programs causing this behavior? And does it happen with the same one(s)?

Not only with games but also with some laucnher apps such as Epic Games launcher using wine via lutris

You might check your DPI and screen resolution.
What graphics card are you running?

sudo lshw -C video

You might consider some adjustments to your Screen Name. This is a "Family Friendly" forum.

1 Like

description: VGA compatible controller
product: Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:46 memory:90000000-9fffffff memory:a8800000-a881ffff ioport:2000(size=256) memory:a8820000-a883ffff
description: Display controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm bus_master cap_list
configuration: driver=i915 latency=0
resources: irq:45 memory:a8000000-a83fffff memory:a0000000-a7ffffff ioport:3000(size=64)

This probably could have been addressed by the Oibaf drivers...

You have Intel integrated graphics and AMD Radeon Dedicated graphics.
What version of OpenGL are you using?

glxinfo | grep "OpenGL version"

You might need to:

sudo apt install mesa-utils

Ensure you have Mesa 19 or higher.

You may need to install the AMDGPU-Pro package.

1 Like

OpenGL version string: 3.1 Mesa 21.2.6

sudo apt install mesa-utils( this is being insatlled right now)

1 Like

is there anything to do next?
do i need to get AMDGPU-Pro package?


Run in terminal:

sudo apt update && sudo apt upgrade

Here is the link to the AMDGPU Pro installer applicable to Focal:

A .deb is a Self Installer package so you can double click on the .deb package to install it.

Alright ty, i installed the .deb package and the terminal code thing.
Radeon™ Software for Linux® Installation — amdgpu graphics and compute stack unknown-build documentation Tho i dont get what do i need to use this for and is there anything else that needs to be done after installing these application , plus the .deb file took me to software from which i insatlled somehting called amdgpu-install

You may need the grub parameter amdgpu.vm_fragment_size=9. That is according to the AMD guide... I am not sure.
To set that:

sudo nano /etc/default/grub

Arrow key down to the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"' You can see it has two parameters already: quiet and splash. Add the amd parameter after those two. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.vm_fragment_size=9"Tapctrl+oto overwrite, then theenterkey to save the current configuration. Tapctrl+x` to exit the editor.
Now, you must run

sudo update-grub

Reboot and test launching a game...

um yeah so i tried and rebooted but the same error occurs.

Have you ensured that you are not logging in on Wayland?

Can you run:

sudo apt install --reinstall gdm3

sudo dpkg-reconfigure gdm3

Follow the prompts to reconfigure the GDM3 Display Manager.

it doesnt show any prompts

I have never heard of a game crash logging the user out... It seems we need to dig deeper into this.
Are you using only Lutris? Or do you have Steam or Play On Linux?
I wonder if this is isolated to Lutris.

I haven't found any information on Genshin being officially supported on Linux... If you are using Steam, try to change the compatibility options and see if any of the other versions of Proton make any difference (Proton Experimental is the default).

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.