While running Zorin, gnome-software's memory consumption keeps increasing

It was less than 200 MiB immediately after startup, but after a few hours it exceeded Firefox.

  • 8 GB RAM
  • Zorin OS 16.1
  • Ryzen 5 2400g with radeon vega graphics

This mean a cache memory ram not closed?

Probably so. Eventually the cache runs out and starts swapping.

In terminal you can choose history and with a "kill" closed them all.

This problem seems to be known. I can deal with it personally, but I would like Zorin OS to address this issue.

Turn off swap and install zRAM

This seems to have been an ongoing issue for some time in all distributions with gnome. This is a gnome issue not a Zorin issue. If you have Timeshift installed, create a new snapshot, and then try the solution:

It does mean you will only be able to use Synaptic, Terminal, or flatpak store to install/remove in future.
Be sure to read all the thread.

1 Like

Thanks, I understand. There are several measures I would like to consider and decide on.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.