Whisker Menu panel problem

OK, I bit the bullet and installed XFCE4 on Zorin Pro 16 then I added Whisker menu. The problem is on the menu panel everything is bunched to the left side of panel. Not sure what happened but can someone tell me how to spread all items out to full panel? See pic below . . .

It has been so long since I've used XFCE, and soon I am going to get a re-training on it when OS 16 LITE is released. But if my memory serves, the settings for the Whisker menu can be found, by right clicking your menu button, and then select Whisker menu settings or whatever it is called.

I seem to remember thats how I did it, and in there should be an option to tell it where you want it to go. You also might be running into an issue where you are overlapping two menu's at once as well, which means your old menu has to be disabled.

Of course I don't remember how to do any of that anymore. Like I said, I need to be re-trained. But if anything I said at all can help you, then I am happy for it. Keep in mind, there might even be some settings burried within the XFCE settings manager as well.

Don't forget to double check your Window Manager, it might have something useful to use as well. And don't forget to right click the panel and check its settings as well. Somehow, someway, we are gonna help you fix this.


Your Tech Support Guru

Looks to me like an issue with wrong placement of separators.

1 Like

Here a pic of the three panel pages:

Never used this menu but I'm sure it's got to be the separators like Jeslin says . . .


Right click on you panel then go to panel>panel preferences. Go to Items and check the placement of your separators. Select a separator and the on the right, click on "Edit the currently selected item " and disable expand feature if you don't want it to expand. You can also drag the items in the items menu to change its position.


Right, do what Jeslin says, and this is where you do it that he's talking about. And see your Whisker menu there, you should be able to config that from there too I think.


In the items tab, click on the Upper most Separator in the list. The one closest to the Whiskermenu.
Now click the Settings icon - in your screenshot, the icons are near to the color of the background making them hard to see, but it is the button right above the Blue Question Mark icon.
Select expand.
You have some unneeded separators below that... It's up to you if you want to fiddle with them.


Got it - thanks all! It was the last separator that needed to be expanded.

1 Like

It looks better now! Congrats!

Any of them could be expanded, actually. Expanding a separator pushes all other elements away in either direction.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.