Why do some software look tiny and/or wrong in Zorin?

The title is pretty self-explanatory. I notice this in a couple of software at Zorin OS 15.

The screenshot contains one of Zorin games ( which look right ) vs

  • Cryptomator ( very small )
  • Notepadqq ( it just looks wrong. )
  • Thinkorswim installation ( This one is the worst. Not only the installation screen looks wrong, it is actually preventing me from installing the software because I have no way to check the box for License agreement.

I really want to like Zorin. The parts that work are beautiful. But, those don't are not even usable at this point.

Please help.

  1. it could be that the "wrong" applications are QT based where Zorin OS is a GTK environment? Just a guess.

  2. Try switch themes. Some times it's a theme thing. Either GTK or the icon theme

  3. Are you running 4K?

Have you tried resizing the thinkorswim installer window by clicking the border corner and dragging? Same for Cryptomator.

Notepadqq is definitely a qt application, not gtk. There is a thread around here somewhere about how to fix that...
But the Brief is:

sudo apt install qt5ct

Once installed, open the app and check if it is using your GTK theme. It may not be and if not, there may be a notification bar at the top saying to remove the environment variable.
If so:
Open /home/$USER/.profile (~/.profile)
add the following lines:

Then run qt5ct configuration tool


Under appearance, style select gtk2. Standard Dialogs: GTK2.
Palette: Default

Log out and in - test.
I noticed that qt apps load slower.

1 Like

Thanks for your help.

I have tried resizing the both thinkorswim and Cryptomator installer window by clicking border corner and dragging. That didn't work.

I tried following your instruction regarding qt5ct. However, I get the following two error as shown in the screenshot.

You may need to check /etc/environment file or the ~.profile file and see what OVERRIDE variable you have set.
Can you take a look and relay what you see?

Please let me know if you need anything else.

The following is .profile

The following is /etc/environment

1 Like

Let's try removing the export QT...=gtk2 variable style and see if qt5ct is bawking because it didn't get to be the one to set it there.
You can comment out the line with a hashtag or remove that line entirely. Save the File.
Then log out and back in and open the qt5ct application (QT5 settings) and try setting the variable within the app. Style Dropdown= gtk2 and Standard Dialogs =GTK2.

I just commented out #export QT_STYLE_OVERRIDE=gtk2 in profile. And, do the rest of the steps. But, I still see the error dialog box with the same two errors.

Also, I am using 4k monitors if that makes any difference per @Storm's comment.

Hmmm... I just tested this on mine and removed those variables, then opened the qt5ct app and it is giving me that same warning. But everything is working properly and the QT apps are displaying in gtk2...
Let me explore the files for a moment...

Ok... Can you look in /etc/profile.d/ directory (As Root) and see if you have a qt-style-override.sh file?
If so, cut and move that file to a safe place (Or just delete or remove it, it is very easy to replace if you feel the need).
You could also try editing it... But I think removing it is better.
There is also a qt-qpa-platformtheme.sh file that needs to go as well.
Then re-trace your steps of log out and in and opening qt5 settings.

I deleted as instructed. And, all I have left are the following. I am still getting that same error when I tried "qt5ct" in the different terminal window.

01-locale-fix.sh cedilla-portuguese.sh vte-2.91.sh
apps-bin-path.sh flatpak.sh xdg_dirs_desktop_session.sh
bash_completion.sh input-method-config.sh

Odd. The above worked in my testing in removing them on mine. Did you Log Out and Back in prior to opening QT5 Settings?

I did not earlier. But, I just tested again with after logging out. The results don't change unfortunately.

I don't know if seeing the full output after typing "qt5ct" is helpful. But, here it is

1 Like

I just tried this search on mine but came up empty-handed. I'd like you to try it anyway...

sudo -i

cd /etc

grep -r "qt-style-override"


  • See if you find anything...

I don't see anything under /etc. That is the command returns empty.

However I tried running the same command under Home as well. The only thing that shows up is "QT_STYLE_OVERRIDE":"adwaita" in one of the jupyter notebook logs. I am not sure it is relevant.

It could be. If it is sending an override that qt5ct is picking up on. I'd suggest removing or quarantining that - Then Log out and in (Sadly, this step is essential to reinitialize) and test qt5ct again.