Why does a program (HomeBank) I'm actively using not show as 'installed' or able to run from command line?

Newbie here. Using OS 16.3. Think I've read all preliminary post notes!
I'm trying to gradually increase my use of Terminal. Latest investigation how to run a program without just 'clicking' on the 'icon' or launcher. Research led me to just type the name of the program after $. It works on randomly selected pre-installed with the OS. It doesn't however work on selected test ones installed through the Software program. Research lead me to various commands and finally with dpkg-query -L Homebank (tried under homebank as well) tells me 'dpkg-query: package 'homebank' is not installed'. Why? HomeBank runs no issue from the 'icon' and launcher.
I have synaptic package manager and a search under 'All' show two entries and the 'Properties' there show 'Status' - Not Installed.
Been going round the circles with Duck Duck go searches and can't get a 'Why' which frustrates this old jigger.
No rush. If an answer is there I'd love to know. My thanks to all out there.

Did you:

sudo apt-get update

before installing?

I don't usually use any form of internet banking due to its poor record on security (I am not talking about the application here, just internet banking in general. Here in the UK, only one bank achieved a security level of 85% which is why I personally stick to phone banking!).

Just for clarity I am currently using MX-Linux 23.1 KDE and whether I use the command line or the icon from the menu, no issues and having checked synaptic package manager after installing from the command line, both homebank and homebank data are present. I would try removing homebank and start again following this guide:


[The current version of homebank that MX installed is 5.6.2-1]

Thank you. No, I haven't used sudo apt-get update at all yet. All updates across the board so far have been through Software Updater, Software, or Synaptic Package Manager (only a couple here to try it out). I do know HomeBank has updated a couple of times as a notification has appeared.
I have previously considered what you suggest and will now action that tomorrow and post the result.
Should it work I'm still left curious as to why it wouldn't now but hey ho that will be a life mystery.
p.s. HomeBank is a very useful financial tool. I migrated from GNUCash which I had run for about 10 years because GNUCash is very full on double entry accounting. HomeBank is simpler and not internet banking (though you can connect). I do so agree with you over internet banking (and much of any internet facility where money is involved).
And that is an admission from an ex bank employee who in 1998 was a fraud investigator (and debt and repossession man years before that) who was seconded to develop the early algorithms to detect fraud. Retired in 2009. But I blame the customers, they leave to 'doors' unlocked and 'windows' open and then blame others when they are robbed.

The software store has access to other types of format packages in addition to the well known .deb packages, known as Flatpak and Snap. From your description of the issue, it sounds like you've installed one of these formats and in fact the flatpak option is selected by default.

You can list packages installed from Flathub (the "store" of Flatpaks) with the command flatpak list, which will also show you the executable which you can input to the terminal to launch it. With Flatpaks this is usually much more verbose as it includes a fully qualified domain similar to how Android apps work. In this case, flatpak run fr.free.Homebank.

1 Like

Whilst some portion of blame can be laid at customers doors and windows, there is a lot of ignorance about how organised crime works and security software not up to standard when it comes to accounts being raided. I have a Linux magazine from a long time ago where the German Police broke their own laws to have a teenager prove how easy it was to use Russian software to remotely take over Internet Explorer in less than 30 seconds making officers believe they were still on a genuine financial website, so I have to disagree with you on that last statement other than the fact that every software that Microsoft has obtained has deteriorated with their poor programming. One of the IT Team where I worked pointed out the principal weakness of Windows ... RPC, Remote Procedure Call. A vector that is not technologically based is where criminals observe bank employees habits and blackmail them to not leak the habits to their employers if they siphon money off to them.

The morning! Thank you swarfendor437 and zenzen. Maybe too old for this, probably out of my newbie depth.
swarfendor437 - couldn't agree more. It's the modern day version of going through peoples dustbins (trash) to collect bills, receipts, cc slips etc to create a profile. Though still done I'm sure. For me - shredder at my side - only if important enough they'll do a jigsaw with the bits but I don't have enough money as an OAP. Shields Up!! Stop now - off pist and post.
zenzen - have the flatpak list on my terminal now but I'm jiggered if I can understand what is showing as the executable. If you mean it, as in your reply fr.free.Homebank, in terminal it gives command not found. What should I look for, if anything? And in Terminal how do I widen the columns like yours - been to preferences and can't see there or in view in menu bar.
Your valuable lesson about software store well taken. I had no idea.
I need now to go into reverse and get more basics understood and right before I go any further. Probably across the board. All packages working for me now as they should so for now, if it ain't broke don't fix it.
I have a little, old notebook I take when travelling. Put Zorin Lite on and want to network via my router but I can see that I'll need to leave that alone for some months!!
I am content with replies so far so will close taking no action but read and learn the manuals more. So much to do, so little time! Grateful thanks.

You can share a screenshot of

flatpak list

if you like. If the output shows anything with Homebank, then you know that Homebank is installed as a Flatpak.
It would not be listed there if it wasn't.

Ah, sorry this was my mistake. To run a flatpak program you need issue the command flatpak run <name_of_package>, so in this case it would be flatpak run fr.free.Homebank.

To stretch out the columns you need to make the terminal window bigger, notice how in my screenshot I have it opened in full screen.

In respect of manuals you could always refer to the unofficial manual I created for Zorin 15 (flatpak and snap is not covered I should add but when Zorin 17 comes out I will be compiling an unofficial manual for that).

Again, thank you swarfendor437. I have that. Have referenced it (or should I say 'looked' at it). Maybe I should read it!
I do thank you all for the knowledge and support.
My steps have been too big. I will have to K.I.S.S.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.