Why does ZorinOS use such an old Kernel

Why does ZorinOS use Kernel 5.4 in their newest release? (ZorinOS Core).
Takes me into some unnecessary Driver Installations, because my Hardware is current gen.

Ok, im hardly confused now.
The Iso i downloaded from the Website was ZorinOS 15...and the newest should be 16.something?

Why is the iso then outdated xD
And also, i am not able to update. This is a completly fresh installation.

Z16 is still beta, but should hit the shelves in a couple of weeks.

1 Like

You might consider Zorin OS 16 (Currently in Beta with Final Release anticipated in a couple of weeks):

It is using the 5.8 kernel.

1 Like

Got everything to work, so i could wait for the new release :slight_smile: Thanks

or jump into Z16 beta. It's rock stable IMO.

And is 5.8 not also completely outdated? XDD


What... If something doesn't have the MSRP sticker still attached, it's completely outdated?

Actually, 5.8 is tested as the highest most stable kernel entrusted with release, but you can manually upgrade to a Higher Mainline kernel.
You can install up to 5.11 using Synaptic, now.

Thanks, my Computer had some really big issues wich took me the whole day to get him working again. Have now no desire to download another iso and set up xD

I don't want to start a discussion here as I definitely haven't read up on kernel versions let alone know what LTS is supposed to mean. But a friend who is very knowledgeable just told me the following:

Both Kernels are outdated, but 5.4 is a LTS Version, so i still gets security updates, but no functional updates any more. 5.8 in the other Hand is completely dead, it is not a LTS Version, so it doesn't get security updates or functional updates.

1 Like

I do understand... especially on the newest machines out there.
In that case... I think Synaptic on Zorin OS 15 goes to 5.8 or so Mainline kernel. It is worth testing and trying out. Really, above 5.6 should do well fo ryou.
But if that is still not enough, you can install unsigned Mainline kernels.

LTS is Long Term Support is updates and patches.

"Outdated" is not the same thing as "non-functional or useless." When it comes to Mass Producing something that you want to work on many various devices, then something can be considered "outdated" the moment it is released and the first Bug Report flows in.
What really matters is whether it performs on your machine.
Your friend is completely correct that 5.8 is not an LTS kernel and is no longer getting updates from Canonical.
However, this is not the same as it not getting patches and fixes on Zorin OS and other ubuntu-derivatives. The purpose is that the kernel is stable and performs well on most machines allowing Zorin OS developers the least concern of breakage. This progresses upward as the 5.8 Stable Kernel with Zorin Patches lasts until Zorin Group releases 5.9, 5.10 and so on.
That does not mean it will work well on all machines - including yours if yours is quite new.
If you use Synaptic, we can help you try installing a newer kernel- or if you like, we can try manually installing a Later Kernel (Unsigned).
I believe that 5.10 is the Current LTS release.

Hm, yes thanks no need currently. Maybe on ZorinOS 16 then.

But other thing. When i try to install nvidia-driver-470 i get many dependency problems. Do you have any fast solution or do i need to find alternative resporities usw.?


The following packages have unmet dependencies:
 nvidia-driver-470 : Depends: libnvidia-extra-470 (= 470.57.02-0ubuntu0.18.04.1) but it is not going to be installed
                     Depends: nvidia-compute-utils-470 (= 470.57.02-0ubuntu0.18.04.1) but it is not going to be installed
                     Depends: nvidia-utils-470 (= 470.57.02-0ubuntu0.18.04.1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-470 (= 470.57.02-0ubuntu0.18.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-470 (= 470.57.02-0ubuntu0.18.04.1) but it is not going to be installed
                     Depends: libnvidia-fbc1-470 (= 470.57.02-0ubuntu0.18.04.1) but it is not going to be installed
                     Recommends: libnvidia-compute-470:i386 (= 470.57.02-0ubuntu0.18.04.1)
                     Recommends: libnvidia-decode-470:i386 (= 470.57.02-0ubuntu0.18.04.1)
                     Recommends: libnvidia-encode-470:i386 (= 470.57.02-0ubuntu0.18.04.1)
                     Recommends: libnvidia-ifr1-470:i386 (= 470.57.02-0ubuntu0.18.04.1)
                     Recommends: libnvidia-fbc1-470:i386 (= 470.57.02-0ubuntu0.18.04.1)
                     Recommends: libnvidia-gl-470:i386 (= 470.57.02-0ubuntu0.18.04.1)
E: Unable to correct problems, you have held broken packages.

Both might apply:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

You may also try:

sudo apt-get install nvidia-current \ nvidia-current-modaliases nvidia-settings

sudo nvidia-xconfig


both methods doesn't seem to work.
The first one doesn't change anything really. Just added a new repository but no new updates.
The other one doesn't find the package "nvidia-current-modaliases", and "nvidia-current" has no installation candidate.

Hmm... Ok, I am trying to find a fast install .deb package for you. This may take a moment- will update this post.

While I am at it, can you go to the App Menu and look up Software & Updates, then check that "Software restricted by copyright..." Is checked to ON?

EDIT: Yep:


Try ensuring that Software Restricted is On, then run the sudo apt full-upgrade command. If still no-go, we can try installing the restricted packages manually, but that may get tedious. Hopefully the above is all that you need.